summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Stenglein2021-08-25 22:04:43 -0400
committerMark Stenglein2021-08-25 22:04:43 -0400
commit50dda62c6161c0bf9d85215e2e02e34aa37c26cd (patch)
tree59517673ddfec0246cbc8bfc5e226e0e0d3fb263
parent895cf7dc12abba4a959349d6d10c9a67fbd668c4 (diff)
downloadaur-50dda62c6161c0bf9d85215e2e02e34aa37c26cd.tar.gz
Release 0.5.0-1
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--CHANGELOG.md218
-rw-r--r--PKGBUILD3
4 files changed, 222 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3e5f4df5dff..a34c4fdd7a1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = slides-git
pkgdesc = Terminal based presentation tool
- pkgver = 0.4.1.r2.g095ea05
+ pkgver = 0.5.0.r0.g4e3be66
pkgrel = 1
url = https://github.com/maaslalani/slides
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 3c527050dfff..0aae0d3ba207 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
-!.CHANGELOG
+!CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..dd733424d446
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,218 @@
+# Changelog
+
+## [0.5.0-1] - 2021-08-25
+
+### Added
+
+#### Slides Customization
+
+Allows you to customize your presentation's look and feel with metadata at the
+top of your `slides.md`. (thanks to [@cuducos](https://github.com/cuducos))
+
+This section is entirely optional, slides will use sensible defaults if this
+section or any field in the section is omitted.
+
+```
+---
+theme: ./path/to/theme.json
+author: Gopher
+date: January 2, 2006
+paging: Slide %d / %d
+---
+```
+
+- `theme`: Path to json file containing a glamour theme, can also be a link to
+ a remote json file which slides will fetch before presenting.
+- `author`: A string to display on the bottom-left corner of the presentation
+ view. Defaults to the OS current user's full name. Can be empty to
+ hide the author.
+- `date`: A string that is used to format today's date in the form
+ 2006-01-02. If the date is not a valid form of 2006-01-02 the
+ contents of the string will be displayed. Defaults to 2006-01-02.
+- `paging`: A string that contains 0 or more %d directives. The first %d will
+ be replaced with the current slide number and the second %d will be
+ replaced with the total slides count. Defaults to Slide %d / %d.
+
+#### Code Block Execution
+
+Added `lua` support.
+
+### Fixed
+
+- Ordered lists now respect the first number as a starting point.
+
+## [0.4.1-1] - 2021-07-05
+
+### Added
+
+- Support for `perl` code execution.
+
+### Fixed
+
+- Custom themes now work (thanks to [@itmecho](https://github.com/itmecho))
+- Slides will not crash with small slides (`<= 1`)
+
+## [0.4.0-1] - 2021-06-27
+
+### Added
+
+#### Pre-processing
+
+`slides` now has the ability to have commands run and executed before
+presenting slides (pre-processing).
+
+To use this feature, you must:
+
+ - Use a file for your slides (no `stdin`, for security reasons)
+ - `chmod +x file.md`, change file permissions to be able to execute code on
+ slides (for security reasons)
+
+In your `slides.md`, you can write a code block with this structure (use tildes
+`~`). When you go to present slides (that are executable,
+`chmod +x slides.md`), `slides` will parse the code block and run the
+`command to run` and pass in the text inside the code block as `stdin` to the
+command. The entire code block will then be replace by the `stdout` of the
+command you want to run.
+
+```
+~~~command to run
+stdin
+~~~
+```
+
+This allows you to:
+
+ - Import text from other files with
+
+```
+~~~xargs cat
+examples/import.md
+~~~
+```
+
+ - Render GraphViz graphs with `graph-easy`
+
+```
+~~~graph-easy --as=boxart
+[ A ] -> [ B ]
+~~~
+```
+
+ - A lot more...
+
+### Changed
+
+- slides added to nixpkgs-unstable @ v0.3.0
+- Added support for javascript code execution (using node)
+- Added support for elixir code execution (thanks to @suzaku)
+- hand Breaking: Removed ~~~ as a slide delimiter (for pre-processing), use --- always instead.
+- Code block execution results are no longer rendered as Markdown. (thanks to @suzaku)
+- Fix bug to be able to parse code blocks without trailing new lines. (thanks to @suzaku)
+
+## [0.3.0-1] - 2021-06-21
+
+### Added
+
+- Support for Live Slides Update by [@sibprogrammer](https://github.com/sibprogrammer)
+
+### Changed
+
+- When there is a code block on the current slide, you can press
+ `ctrl+e` to execute it and the output will display as virtual
+ text on the slide at the end. Supported languages are bash, ruby,
+ python, and go.
+
+## [0.2.0-1] - 2021-06-13
+
+### Added
+
+- Execute code blocks for supported languages (bash, go, ruby, python)
+- User customizable themes.
+
+## [0.1.2-1] - 2021-06-09
+
+### Added
+
+- Allows users to pipe in slides from `stdin` which allows for
+ `curl`ing remote slides and presenting them as well as piping
+ multiple files into one (with `cat`) and much more.
+- Allow users to specify any chroma supported theme instead of
+ manually specifying colors.
+
+### Fixed
+
+- Fix `go vet ./...` Redefinition
+ - https://github.com/maaslalani/slides/issues/14
+- Fix the displayed date format
+ - https://github.com/maaslalani/slides/issues/11
+
+### AUR
+
+#### Fixed
+
+- Added `check()` back into the build.
+
+#### Added
+
+- Added this changelog document.
+
+## [0.1.1-3] - 2021-06-09
+
+### AUR
+
+#### Added
+
+- Added note in PKGBUILD about broken `check()` functionality due to
+ https://github.com/maaslalani/slides/issues/14
+
+## [0.1.1-2] - 2021-06-08
+
+### AUR
+
+#### Changed
+
+- Fixed declared PKGBUILD dependencies.
+
+## [0.1.1-1] - 2021-06-07
+
+- 0e97b0a Merge pull request #10 from meowgorithm/bump-libs
+- 5e39ade Update deprecated method of entering the altscreen
+- e90da58 Update bubbletea/bubbles/glamour/lipgloss dependencies
+- 6672f28 Update README.md
+- 93ccd25 Internal API
+
+## [0.1.0] - 2021-06-06
+
+- 22b6fa2 go 1.16
+- 6699e8a Create goreleaser.yml
+- 95634ae Merge pull request #6 from sibprogrammer/bugfix-slide-separator
+- 2489fac Merge pull request #8 from sibprogrammer/bugfix-slide-numbers
+- 4e94e57 Merge pull request #4 from sibprogrammer/bugfix-makefile-errors
+- a108f30 Fix #7 Display the correct number of slides and current one
+- 0a15388 Fix #5 Allow to use triple dashes as a slide separator
+- adb8dba Fix Makefile errors
+- 47d2a87 embed styles
+- 9b249b6 Revert "no need for user to specify theme.json"
+- 7af1081 no need for user to specify theme.json
+- e90002f Merge pull request #3 from angristan/render-error
+- 17a5ed7 Show markdown rendering error to user
+- cb40fa9 pr template
+- 9480b07 Create CONTRIBUTING.md
+- 9be3b16 Update issue templates
+- 59326ce add space as next slides, swap down & up keys
+- 1c6b5df Add credits
+- 0f1ebff remove double import
+- ffca702 moar
+- eceb2c4 lil more error handling
+- 44cfcf6 Remove hardcoded values
+- babdab1 Move demo to top
+- 6ed3fe6 Add readme.md
+- 0c87800 Create makefile
+- 1cf7d3f Create license
+- debbccc theme.json
+- 20c68ad JoinVertical
+- 5bcb013 progress
+- d27e870 WIP
+- 39df02c Markdown
+- 6fc439b Initial commit
+
diff --git a/PKGBUILD b/PKGBUILD
index 5900db2bddac..45de5f0b013b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Stenglein <aur@markstenglein.com>
pkgname=slides-git
-pkgver=0.4.1.r2.g095ea05
+pkgver=0.5.0.r0.g4e3be66
pkgrel=1
pkgdesc='Terminal based presentation tool'
arch=('x86_64')
@@ -13,6 +13,7 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" "${pkgname%-git}-bin")
source=("${pkgname%-git}::git+$url.git")
sha256sums=('SKIP')
+changelog='CHANGELOG.md'
pkgver() {
cd ${pkgname%-git}