summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelixoid2016-04-18 01:23:25 +0300
committerfelixoid2016-04-18 01:23:25 +0300
commitc8a00f02c113faaa1dc92f017ddd0e5c3fb6de73 (patch)
treea1b13e8b49fc55aac55db7da521a73592aec45e3
downloadaur-c8a00f02c113faaa1dc92f017ddd0e5c3fb6de73.tar.gz
create github repo and restore sources to there
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--burning-arch.install13
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce1c231c2ac0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = slim-theme-burning-arch
+ pkgdesc = Slim theme for ArchLinux
+ pkgver = 1.0
+ pkgrel = 4
+ url = https://sourceforge.net/projects/slimburningarch/
+ install = burning-arch.install
+ arch = any
+ license = custom
+ depends = slim
+ source = http://sourceforge.net/projects/slimburningarch/files/1.0/slim-theme-burning-arch-1.0.tar.gz
+ md5sums = 2c7444637b2ad05ac28470ea0419b3a1
+
+pkgname = slim-theme-burning-arch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7206188fb130
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Chirantan Ekbote <chirantan.ekbote at gmail.com>
+# Contributor: SiD/sidious <miste7@web.de>
+# Contributor: Mikhail Felixoid Shiryaev <mr.felixoid gmail.com>
+
+pkgname=slim-theme-burning-arch-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Slim theme for ArchLinux"
+license=('custom')
+arch=('any')
+url="https://github.com/Felixoid/slim-theme-burning-arch"
+depends=('slim')
+makedepends=('git')
+conflicts=('slim-theme-burning-arch')
+install=burning-arch.install
+source=("${pkgname}::git+https://github.com/Felixoid/slim-theme-burning-arch.git")
+md5sums=('SKIP')
+
+package() {
+ cd ${srcdir}/${pkgname}/src/
+
+ cp -r usr/ ${pkgdir}/
+}
diff --git a/burning-arch.install b/burning-arch.install
new file mode 100644
index 000000000000..a1a821cc18af
--- /dev/null
+++ b/burning-arch.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "==> Edit your /etc/slim.conf and change the current_theme to burning-arch:"
+ echo "==> current_theme burning-arch"
+}
+
+post_remove() {
+ echo "==> Edit your /etc/slim.conf and change the current_theme for"
+ echo "==> a another theme than burning-arch"
+}
+
+op=$1
+shift
+$op $*