summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-24 16:15:07 -0700
committeryochananmarqos2019-12-24 16:15:07 -0700
commit7b6b5e7c7c9bb79dbe985ca380ec66a4e4b664fe (patch)
treed17bfd01e8959363041e8304ceb01096730a12b4
parent1445521df338d0b2bd2ad3bb51acb6a19e1e6fe3 (diff)
downloadaur-7b6b5e7c7c9bb79dbe985ca380ec66a4e4b664fe.tar.gz
updated dependencies
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD29
-rw-r--r--slimbookbattery.install16
3 files changed, 28 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce55bfdb0a2f..043909b9617c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,26 @@
pkgbase = slimbookbattery
- pkgdesc = Slimbook Battery. Is a battery optimization application for portable devices that can increase the battery life by 50%. For this purpose, the third-party software (TLP and others) is used to manage and configure the system resources.
+ pkgdesc = A battery optimization application for portable devices
pkgver = 3.10beta
- pkgrel = 2
+ pkgrel = 3
url = http://slimbook.es
install = slimbookbattery.install
arch = any
- license = Creative Commons BY-NC-ND 3.0
- depends = bash-completion
- depends = desktop-file-utils
- depends = gdk-pixbuf2
- depends = glib2
- depends = gobject-introspection-runtime
- depends = hicolor-icon-theme
- depends = libappindicator-gtk2
- depends = libappindicator-gtk3
- depends = libindicator-gtk2
- depends = libnotify
- depends = logwatch
- depends = python
- depends = python-cairo
- depends = python-dbus
+ license = CC BY-NC-ND 3.0
depends = python-gobject
+ depends = python-cairo
depends = python-pillow
- depends = tlp
+ depends = python-dbus
+ depends = libappindicator-gtk3
+ depends = gdk-pixbuf2
+ depends = libnotify
depends = tlp-rdw
+ depends = cron
+ depends = dmidecode
depends = xorg-xdpyinfo
- options = !strip
- options = !emptydirs
- backup = etc/systemd/system/suspend-sedation.service
+ optdepends = arch-prime-git: for hybrid graphics switching
+ optdepends = gnome-shell-extension-appindicator: for tray icon on GNOME
source = https://launchpad.net/~slimbook/+archive/ubuntu/slimbook/+files/slimbookbattery_3.10beta_all.deb
- sha512sums = c37eb6c159ec4ea94f9d6e8066359433bb9923b1999a8a7d22036e2177cf410adb6ff1126b5cb96d275e958a1087b7660cea9a05d3a61ac81f60ac8e947edb39
+ sha256sums = da8397b2184af90b788c388d262b7fbf8d82181d30f6009db64ea5ef2071e980
pkgname = slimbookbattery
diff --git a/PKGBUILD b/PKGBUILD
index 5e402604e953..1c2d5d7939da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: tioguda <guda.flavio@gmail.com>
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: tioguda <guda.flavio@gmail.com>
pkgname=slimbookbattery
pkgver=3.10beta
-pkgrel=2
-pkgdesc="Slimbook Battery. Is a battery optimization application for portable devices that can increase the battery life by 50%. For this purpose, the third-party software (TLP and others) is used to manage and configure the system resources."
+pkgrel=3
+pkgdesc="A battery optimization application for portable devices"
arch=('any')
url="http://slimbook.es"
-license=('Creative Commons BY-NC-ND 3.0')
-groups=()
-depends=('bash-completion' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'gobject-introspection-runtime' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libappindicator-gtk3' 'libindicator-gtk2' 'libnotify' 'logwatch' 'python' 'python-cairo' 'python-dbus' 'python-gobject' 'python-pillow' 'tlp' 'tlp-rdw' 'xorg-xdpyinfo')
-backup=('etc/systemd/system/suspend-sedation.service')
-options=('!strip' '!emptydirs')
-install=${pkgname}.install
+license=('CC BY-NC-ND 3.0')
+depends=('python-gobject' 'python-cairo' 'python-pillow' 'python-dbus' 'libappindicator-gtk3'
+ 'gdk-pixbuf2' 'libnotify' 'tlp-rdw' 'cron' 'dmidecode' 'xorg-xdpyinfo')
+optdepends=('arch-prime-git: for hybrid graphics switching'
+ 'gnome-shell-extension-appindicator: for tray icon on GNOME')
+install="$pkgname.install"
source=("https://launchpad.net/~slimbook/+archive/ubuntu/slimbook/+files/${pkgname}_${pkgver}_all.deb")
-sha512sums=('c37eb6c159ec4ea94f9d6e8066359433bb9923b1999a8a7d22036e2177cf410adb6ff1126b5cb96d275e958a1087b7660cea9a05d3a61ac81f60ac8e947edb39')
+sha256sums=('da8397b2184af90b788c388d262b7fbf8d82181d30f6009db64ea5ef2071e980')
-package(){
- # Extract package data
- tar xf data.tar.xz -C "${pkgdir}"
+package() {
+ tar xf data.tar.xz -C "$pkgdir"
- install -D -m644 "${pkgdir}/usr/share/doc/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "$pkgdir/usr/share/doc/$pkgname/copyright" -t "$pkgdir/usr/share/licenses/$pkgname"
}
diff --git a/slimbookbattery.install b/slimbookbattery.install
index c3a3e298cc0b..681ba5a05044 100644
--- a/slimbookbattery.install
+++ b/slimbookbattery.install
@@ -1,7 +1,4 @@
post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
-
python3 -OO -m py_compile /usr/share/slimbookbattery/preferences.py
python3 -OO -m py_compile /usr/share/slimbookbattery/slimbookbattery
python3 -OO -m py_compile /usr/share/slimbookbattery/slimbookbattery-changemode.py
@@ -20,10 +17,7 @@ post_install() {
rm /usr/share/slimbookbattery/__pycache__/*
rmdir /usr/share/slimbookbattery/__pycache__
- echo "Warning."
- echo "It is highly recommended that you disable any other battery/power management program. For example, the tlpui."
-
- update-desktop-database -q
+ chmod +x /usr/share/slimbookbattery/bin/*
}
post_upgrade() {
@@ -31,13 +25,5 @@ post_upgrade() {
}
post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
rm -rf /usr/share/slimbookbattery
-
- for d in /home/*/ ; do
- rm -rf $d/.config/slimbookbattery
- done
-
- update-desktop-database -q
}