summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-04-20 23:52:40 +0200
committerhaawda2017-04-20 23:52:40 +0200
commit1553591e842d9e654e13a802ce3c932adf8a7327 (patch)
tree0a9a65bbbd7f55a45a9ffab1b6e5591bdbfaf20b
parent3e67b4b7d502ece8aa3aa09f66970215e07a973c (diff)
downloadaur-1553591e842d9e654e13a802ce3c932adf8a7327.tar.gz
add patch for not bytecompiling one file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--hyperdoc.patch11
3 files changed, 27 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff63226d91d9..57d1b6f1df51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 22 22:56:35 UTC 2017
+# Thu Apr 20 21:51:56 UTC 2017
pkgbase = slime-git
pkgdesc = The Superior Lisp Interaction Mode for Emacs - from git
- pkgver = 2.19.6.g0f3459f5
+ pkgver = 2.19.11.g90771f1a
pkgrel = 1
url = http://common-lisp.net/project/slime
install = slime.install
@@ -18,7 +18,9 @@ pkgbase = slime-git
provides = slime
conflicts = slime
source = git://github.com/slime/slime
+ source = hyperdoc.patch
md5sums = SKIP
+ md5sums = 54d14889a58ad2930861002b5a2c4741
pkgname = slime-git
diff --git a/PKGBUILD b/PKGBUILD
index 7b31b9aa0f00..d55b659a59b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=slime-git
-pkgver=2.19.6.g0f3459f5
+pkgver=2.19.11.g90771f1a
pkgrel=1
pkgdesc="The Superior Lisp Interaction Mode for Emacs - from git"
arch=('any')
@@ -16,22 +16,27 @@ optdepends=('awk: for recreating the documentation'
provides=('slime')
conflicts=('slime')
install=slime.install
-source=("git://github.com/slime/slime")
-md5sums=('SKIP')
-_gitname="slime"
+source=("git://github.com/slime/slime" hyperdoc.patch)
+md5sums=('SKIP'
+ '54d14889a58ad2930861002b5a2c4741')
pkgver() {
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
echo $(git describe --tags | sed 's|-|.|g'|cut -c2-)
}
+prepare(){
+ cd ${pkgname%-git}/contrib
+ patch -Np0 < "$srcdir"/hyperdoc.patch || true
+}
+
build() {
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
make
}
package() {
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
install -d $pkgdir/usr/share/emacs/site-lisp/slime
cp -r $srcdir/slime/* \
$pkgdir/usr/share/emacs/site-lisp/slime
diff --git a/hyperdoc.patch b/hyperdoc.patch
new file mode 100644
index 000000000000..aeb28e596ee9
--- /dev/null
+++ b/hyperdoc.patch
@@ -0,0 +1,11 @@
+--- Makefile 2017-04-20 18:53:41.661375694 +0200
++++ Makefile.new 2017-04-20 23:47:04.867298921 +0200
+@@ -10,7 +10,7 @@
+ CONTRIB_TESTS = $(patsubst test/slime-%-tests.el,%,$(wildcard test/slime-*.el))
+ SLIME_VERSION=$(shell grep "Version:" ../slime.el | grep -E -o "[0-9.]+$$")
+
+-ELFILES := $(shell find . -type f -iname "*.el")
++ELFILES := $(shell find . -type f -iname "*.el"|grep -v hyperdoc)
+ ELCFILES := $(patsubst %.el,%.elc,$(ELFILES))
+
+ %.elc: %.el