summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-03-28 13:55:20 +0800
committerzxp198210052023-03-28 13:55:20 +0800
commitcac1a26727d6fcda87873ed12f4fbaaf2ffc08a0 (patch)
tree053a429a9411d6870c47199d5bddc3467ea0d0cf
parentaefeda1ee43714b7a57a4d740ce5c1472e45e817 (diff)
downloadaur-cac1a26727d6fcda87873ed12f4fbaaf2ffc08a0.tar.gz
update to 38.0.7.0
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD28
3 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5075515300bf..65e45a2fc94d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = slimjet
pkgdesc = Fast, smart and powerful browser based on Blink
- pkgver = 38.0.6.0
+ pkgver = 38.0.7.0
pkgrel = 1
url = https://www.slimjet.com
+ install = slimjet.install
arch = x86_64
license = custom:freeware
depends = libxcb
@@ -34,11 +35,13 @@ pkgbase = slimjet
conflicts = slimjet35
options = !emptydirs
options = !strip
- source = slimjet-38.0.6.0_amd64.deb::https://www.slimjetbrowser.com/release/slimjet_amd64.deb
+ source = slimjet-38.0.7.0_amd64.deb::https://www.slimjetbrowser.com/release/slimjet_amd64.deb
source = libffmpeg-0.73.0.zip::https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt/releases/download/0.73.0/0.73.0-linux-x64.zip
- source = LICENSE
- sha256sums = ecf843076df2d911c5fd81ccd6513df4d897a6655d3f289da79db64c776c3cfd
+ source = LICENSE::https://www.slimjet.com/en/webhelp/index.htm
+ source = slimjet.install
+ sha256sums = 5af0315d02460a592fe7cf4928dfb1649ca4ee81d4026c7abfd57cfa2ff6b4ea
sha256sums = 8cad02e111745402d411414d8f8d15f1504bbcd884ccf050dfad252a63ad633a
- sha256sums = fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e
+ sha256sums = 2c9dac1462b349e7c077ea33cdc91ff46563b2ca0457617958772a689b4c8d43
+ sha256sums = 2bfc097100279ec967fe51bd413140dfd10e095ac8005729455f9fef884723c8
pkgname = slimjet
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index ab0d0bcdd61c..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,3 +0,0 @@
- Slimjet Web Browser is released under the freeware license. It is free both for personal use and commerical use. It is free to be distributed over the internet and/or
- through offline distribution channels as long as it is kept in its original form without any change. Bundling Slimjet with other software in another installer is strictly
- prohibited.
diff --git a/PKGBUILD b/PKGBUILD
index ec3ac13f6151..fc24343a9858 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Original Maintainer: raininja <dandenkijin@gmail.com>
-# Contributor: eagleeyetom <eagleeyetom@gmail.com>
-# Maintainer: dalto <dalto[at]fastmail.com>
+# Contributor: raininja <dandenkijin ad gmail dot com>
+# Contributor: eagleeyetom <eagleeyetom at gmail dot com>
+# Contributor: dalto <dalto at fastmail dot com>
+# Maintainer: ahmedmoselhi
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=slimjet
-pkgver=38.0.6.0
+pkgver=38.0.7.0
pkgrel=1
_libffmpegverurl="https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt/releases"
_libffmpegver=0.73.0
@@ -15,24 +16,25 @@ license=('custom:freeware')
depends=(libxcb at-spi2-core libxdamage libxcomposite pango gcc-libs libxkbcommon libxrandr alsa-lib bash \
libcups glib2 dbus nspr nss libdrm hicolor-icon-theme libxfixes expat glibc libx11 mesa cairo libxext)
optdepends=('kdialog: needed for file dialogs in KDE' 'ttf-liberation: fix fonts for some PDFs')
-conflicts=('slimjet35')
+conflicts=("${pkgname}35")
+install="${pkgname}.install"
options=('!emptydirs' '!strip')
-source=(
- "${pkgname}-${pkgver}_amd64.deb::${_downurl}/release/${pkgname}_amd64.deb"
+source=("${pkgname}-${pkgver}_amd64.deb::${_downurl}/release/${pkgname}_amd64.deb"
"libffmpeg-${_libffmpegver}.zip::${_libffmpegverurl}/download/${_libffmpegver}/${_libffmpegver}-linux-x64.zip"
- "LICENSE"
- )
-sha256sums=('ecf843076df2d911c5fd81ccd6513df4d897a6655d3f289da79db64c776c3cfd'
+ "LICENSE::${url}/en/webhelp/index.htm"
+ "${pkgname}.install")
+sha256sums=('5af0315d02460a592fe7cf4928dfb1649ca4ee81d4026c7abfd57cfa2ff6b4ea'
'8cad02e111745402d411414d8f8d15f1504bbcd884ccf050dfad252a63ad633a'
- 'fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e')
+ '2c9dac1462b349e7c077ea33cdc91ff46563b2ca0457617958772a689b4c8d43'
+ '2bfc097100279ec967fe51bd413140dfd10e095ac8005729455f9fef884723c8')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}"
- bsdtar -xf libffmpeg-${_libffmpegver}.zip -C "${pkgdir}/opt/${pkgname}/"
+ bsdtar -xf "${srcdir}/libffmpeg-${_libffmpegver}.zip" -C "${pkgdir}/opt/${pkgname}/"
find "${pkgdir}" -type d -exec chmod 755 {} \;
install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
install -Dm644 "${pkgdir}"/opt/slimjet/product_logo_${i/x*}.png \
"${pkgdir}"/usr/share/icons/hicolor/${i}/apps/flashpeak-slimjet.png
done
-} \ No newline at end of file
+}