summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-11 12:29:25 +0800
committerzxp198210052023-10-11 12:29:25 +0800
commit64a64a47752ee4202d5d4c5f62cfc4998125da93 (patch)
treef3ce319504ef995973896d532a70c1d38646dd5d
parent9a34ad32fb8252459c9c1eecfc0534d107d1ce95 (diff)
downloadaur-64a64a47752ee4202d5d4c5f62cfc4998125da93.tar.gz
update to 41.0.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b0c5f032607..b554b42eceeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = slimjet-beta-bin
pkgdesc = Fast, smart and powerful browser based on Blink
- pkgver = 40.0.0.0
+ pkgver = 41.0.0.0
pkgrel = 1
url = https://www.slimjet.com
arch = x86_64
@@ -22,7 +22,6 @@ pkgbase = slimjet-beta-bin
depends = nspr
depends = nss
depends = libdrm
- depends = hicolor-icon-theme
depends = libxfixes
depends = expat
depends = glibc
@@ -35,11 +34,11 @@ pkgbase = slimjet-beta-bin
conflicts = slimjet
options = !emptydirs
options = !strip
- source = slimjet-beta-40.0.0.0_amd64.deb::https://www.slimjetbrowser.com/beta/slimjet_amd64.deb
- source = libffmpeg-0.77.0.zip::https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt/releases/download/0.77.0/0.77.0-linux-x64.zip
+ source = slimjet-beta-41.0.0.0_amd64.deb::https://www.slimjetbrowser.com/beta/slimjet_amd64.deb
+ source = libffmpeg-0.80.0.zip::https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt/releases/download/0.80.0/0.80.0-linux-x64.zip
source = LICENSE.html::https://www.slimjet.com/en/webhelp/index.htm
- sha256sums = 3ce02b395d82e88e6452d3d0797741ccf630c536c21d3a7adbae42ce7cf79826
- sha256sums = 9d56e4e6c9081fb5bdb92896b630a0bcb4274f33f5e7c96c16b945bc30fd7d02
+ sha256sums = 17e42f09137b1884a4509d96d7f99d0226ea3c0be3271364b25fe0731c0c5972
+ sha256sums = 8afa2102c5bc6e74ac8e812a78c72fbc6342443d06f42098cf496d8ea81529a9
sha256sums = 2c9dac1462b349e7c077ea33cdc91ff46563b2ca0457617958772a689b4c8d43
pkgname = slimjet-beta-bin
diff --git a/PKGBUILD b/PKGBUILD
index 38fd50d530a3..305d13b5600e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,39 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
_pkgname=slimjet
pkgname="${_pkgname}-beta-bin"
-pkgver=40.0.0.0
+_appname="flashpeak-${_pkgname}"
+pkgver=41.0.0.0
pkgrel=1
_libffmpegverurl="https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt"
-_libffmpegver=0.77.0
+_libffmpegver=0.80.0
pkgdesc="Fast, smart and powerful browser based on Blink"
arch=('x86_64')
url="https://www.slimjet.com"
_downurl="https://www.slimjetbrowser.com"
license=('custom:freeware')
depends=('libxcb' 'at-spi2-core' 'libxdamage' 'libxcomposite' 'pango' 'gcc-libs' 'libxkbcommon' 'libxrandr' 'alsa-lib' 'sh' 'libxext'\
- 'libcups' 'glib2' 'dbus' 'nspr' 'nss' 'libdrm' 'hicolor-icon-theme' 'libxfixes' 'expat' 'glibc' 'libx11' 'mesa' 'cairo')
+ 'libcups' 'glib2' 'dbus' 'nspr' 'nss' 'libdrm' 'libxfixes' 'expat' 'glibc' 'libx11' 'mesa' 'cairo')
optdepends=('kdialog: needed for file dialogs in KDE' 'ttf-liberation: fix fonts for some PDFs')
conflicts=("${_pkgname}35" "${_pkgname}")
options=('!emptydirs' '!strip')
source=("${pkgname%-bin}-${pkgver}_amd64.deb::${_downurl}/beta/${_pkgname}_amd64.deb"
"libffmpeg-${_libffmpegver}.zip::${_libffmpegverurl}/releases/download/${_libffmpegver}/${_libffmpegver}-linux-x64.zip"
"LICENSE.html::${url}/en/webhelp/index.htm")
-sha256sums=('3ce02b395d82e88e6452d3d0797741ccf630c536c21d3a7adbae42ce7cf79826'
- '9d56e4e6c9081fb5bdb92896b630a0bcb4274f33f5e7c96c16b945bc30fd7d02'
+sha256sums=('17e42f09137b1884a4509d96d7f99d0226ea3c0be3271364b25fe0731c0c5972'
+ '8afa2102c5bc6e74ac8e812a78c72fbc6342443d06f42098cf496d8ea81529a9'
'2c9dac1462b349e7c077ea33cdc91ff46563b2ca0457617958772a689b4c8d43')
-
+build() {
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ find "${srcdir}" -type d -exec chmod 755 {} \;
+}
package() {
- bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
- install -Dm644 "${srcdir}/libffmpeg.so" -t "${pkgdir}/opt/${_pkgname}/"
- find "${pkgdir}" -type d -exec chmod 755 {} \;
+ install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
+ cp -r "${srcdir}/opt/${_pkgname}" "${pkgdir}/opt"
+ ln -sf "/opt/${_pkgname}/${_appname}" "${pkgdir}/usr/bin/${_appname}"
+ install -Dm644 "${srcdir}/libffmpeg.so" -t "${pkgdir}/opt/${_pkgname}"
install -Dm644 "${srcdir}/LICENSE.html" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- for _icons in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
- install -Dm644 "${pkgdir}/opt/${_pkgname}/product_logo_${_icons/x*}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/flashpeak-slimjet.png"
- done
- chmod 0755 "${pkgdir}/opt/${_pkgname}/${_pkgname}-sandbox"
+ install -Dm644 "${srcdir}/usr/share/applications/${_pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/usr/share/gnome-control-center/default-apps/${_pkgname}.xml" -t "${pkgdir}/usr/share/gnome-control-center/default-apps".
+ install -Dm644 "${srcdir}/usr/share/menu/${_pkgname}.menu" -t "${pkgdir}/usr/share/menu"
+ install -Dm644 "${srcdir}/usr/share/pixmaps/${_pkgname}.xpm" -t "${pkgdir}/usr/share/pixmaps"
} \ No newline at end of file