summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorergotamin2019-01-08 18:45:06 +0100
committerergotamin2019-01-08 18:45:06 +0100
commit11090b4231d8db8a7bf8ae7c6e3e86dda5be21da (patch)
treeef9726164cdb7c4375bba9cd531cdfb1a9886c5a
parent045ec8282d87249a2899b880bd84410f95b85783 (diff)
downloadaur-11090b4231d8db8a7bf8ae7c6e3e86dda5be21da.tar.gz
Update to latest-release...
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD93
-rwxr-xr-xslimjet-browser30
-rw-r--r--slimjet-browser.install23
4 files changed, 78 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa95ec7749d2..93afe27b4894 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = slimjet-browser
- pkgdesc = A lightweight Browser based on Blink (without setuid-sandbox)
- pkgver = 21.0.7.0
+ pkgdesc = A lightweight Browser based on Blink (removed setuid-sandbox)
+ pkgver = 21.0.8.0
pkgrel = 1
url = http://www.slimjet.com
install = slimjet-browser.install
@@ -36,11 +36,11 @@ pkgbase = slimjet-browser
replaces = slimjet
options = !emptydirs
options = !strip
- source = slimjet-browser-21.0.7.0-x86_64.deb::https://www.slimjet.com/release/archive/21.0.7.0/slimjet_amd64.deb
+ source = slimjet-browser-x86_64.deb::https://www.slimjetbrowser.com/release/slimjet_amd64.deb
source = LICENSE
source = flashpeak.patch
source = slimjet-browser
- sha256sums = 2ee03c092d124d58afb6e52c39d16284d82eec724d0b223b15c93dc057f0f388
+ sha256sums = SKIP
sha256sums = fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e
sha256sums = 9ec7ee8938b2f88fe0130abe4aa886a90da97003bfc08d20937612d75ee9f228
sha256sums = 74759fb197d997661b891d73bbc30a5d9b82183457fc10d3695cbb3f20a3111c
diff --git a/PKGBUILD b/PKGBUILD
index ea3f2cd21bdb..737aa60c20aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,63 +2,64 @@
# Contributor: visit ""
pkgname=('slimjet-browser')
_origname='slimjet'
-pkgver=21.0.7.0
+pkgver=21.0.8.0
pkgrel=1
-pkgdesc="A lightweight Browser based on Blink (without setuid-sandbox)"
+pkgdesc="A lightweight Browser based on Blink (removed setuid-sandbox)"
arch=('x86_64')
url="http://www.slimjet.com"
depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme' 'xorg-xhost'
- 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'openssl' 'nspr' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
+ 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'openssl' 'nspr' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
optdepends=('kdebase-kdialog: needed for file dialogs in KDE' 'ttf-liberation: fix fonts for some PDFs')
makedepends=('pacman>=4.2.0' 'imagemagick>7.0.0')
options=('!emptydirs' '!strip')
provides=('slimjet-browser')
replaces=('slimjet')
license=('custom:freeware' 'MIT')
-source=("${pkgname}-${pkgver}-${arch}.deb::https://www.${_origname}.com/release/archive/${pkgver}/${_origname}_amd64.deb"
- "LICENSE"
- "flashpeak.patch"
- "slimjet-browser")
+source=("${pkgname}-${arch}.deb::https://www.${_origname}browser.com/release/${_origname}_amd64.deb"
+ "LICENSE"
+ "flashpeak.patch"
+ "slimjet-browser")
install='slimjet-browser.install'
-sha256sums=('2ee03c092d124d58afb6e52c39d16284d82eec724d0b223b15c93dc057f0f388'
- 'fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e'
- '9ec7ee8938b2f88fe0130abe4aa886a90da97003bfc08d20937612d75ee9f228'
- '74759fb197d997661b891d73bbc30a5d9b82183457fc10d3695cbb3f20a3111c')
+sha256sums=('SKIP'
+ 'fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e'
+ '9ec7ee8938b2f88fe0130abe4aa886a90da97003bfc08d20937612d75ee9f228'
+ '74759fb197d997661b891d73bbc30a5d9b82183457fc10d3695cbb3f20a3111c')
package() {
- msg2 "Extracting data.tar.xz of ${pkgname}-${pkgver}-${arch}.deb ..."
- # needed
- bsdtar -xpf "data.tar.xz"
- #-
- msg2 "Sanitizing extracted file-tree ..."
- # trash
- rm -f 'control.tar.gz' 'debian-binary'
- rm -f "usr/bin/flashpeak-slimjet"
- rm -rf "usr/share/doc"
- # license
- mkdir -p "usr/share/licenses/${pkgname}"
- install "${srcdir}/LICENSE" "usr/share/licenses/${pkgname}"
- # icon-format->PNG
- $(command -v convert) "usr/share/pixmaps/slimjet.xpm" "usr/share/pixmaps/slimjet.png" &>/dev/zero
- sed 's%^Exec=/usr/bin/flashpeak-slimjet%Exec=/usr/bin/slimjet-browser%g' -i "usr/share/applications/slimjet.desktop"
- sed 's%^Icon=flashpeak-slimjet%Icon=slimjet%g' -i "usr/share/applications/slimjet.desktop"
- # deleted check for slimjet-sandbox
- patch "opt/slimjet/flashpeak-slimjet" < "${srcdir}/flashpeak.patch"
- # removing deprecated setuid-sandbox, namespaced-sandbox will be used
- rm -f "opt/slimjet/slimjet-sandbox"
- mv "opt/slimjet" "usr/share/slimjet"
- # cleanup
- rm -rf "opt"
- # setup kernel to permit namespaced sandbox, and
- # if run as root, the dummy user slim-root executes slimjet
- install -m0755 "${srcdir}/slimjet-browser" "usr/bin/slimjet-browser"
- #-
- msg2 "Moving sanitized file-tree to package-directory ..."
- # moving to target-directory
- mv --target-directory="${pkgdir}" usr
- # setting correct permissions
- chmod -R 0755 "${pkgdir}/"
- # done
- msg2 "Finished packaging !"
- # enjoy !
+ msg2 "Extracting data.tar.xz of ${pkgname}-${arch}.deb ..."
+ # needed
+ bsdtar -xpf "data.tar.xz"
+ #-
+ msg2 "Sanitizing extracted file-tree ..."
+ # trash
+ rm -f 'control.tar.gz' 'debian-binary'
+ rm -f "usr/bin/flashpeak-slimjet"
+ rm -rf "usr/share/doc"
+ # license
+ mkdir -p "usr/share/licenses/${pkgname}"
+ install "${srcdir}/LICENSE" "usr/share/licenses/${pkgname}"
+ # icon-format->PNG
+ $(command -v convert) "usr/share/pixmaps/slimjet.xpm" "usr/share/pixmaps/slimjet.png" &>/dev/zero
+ # use attached wrapper
+ sed 's%^Exec=/usr/bin/flashpeak-slimjet%Exec=/usr/bin/slimjet-browser%g' -i "usr/share/applications/slimjet.desktop"
+ sed 's%^Icon=flashpeak-slimjet%Icon=slimjet%g' -i "usr/share/applications/slimjet.desktop"
+ # deleted check for slimjet-sandbox
+ patch "opt/slimjet/flashpeak-slimjet" <"${srcdir}/flashpeak.patch"
+ # removing deprecated setuid-sandbox, namespaced-sandbox will be used
+ rm -f "opt/slimjet/slimjet-sandbox"
+ mv "opt/slimjet" "usr/share/slimjet"
+ # cleanup
+ rm -rf "opt"
+ # setup kernel to permit namespaced sandbox, and
+ # if run as root, the dummy user slim-root executes slimjet
+ install -m0755 "${srcdir}/slimjet-browser" "usr/bin/slimjet-browser"
+ #-
+ msg2 "Moving sanitized file-tree to package-directory ..."
+ # moving to target-directory
+ bsdtar -pcf - usr | bsdtar -pxf - -C "$pkgdir"
+ # setting correct permissions
+ chmod -R 0755 "${pkgdir}/"
+ # done
+ msg2 "Finished !"
+ # enjoy !
}
diff --git a/slimjet-browser b/slimjet-browser
index b74ddba9bcd0..4e6d44e81ec0 100755
--- a/slimjet-browser
+++ b/slimjet-browser
@@ -1,22 +1,16 @@
#!/bin/bash
-if [[ `id -u` -eq 0 ]]; then
- if [[ `cat /proc/sys/kernel/unprivileged_userns_clone` -eq 0 ]]; then
- echo 1 > /proc/sys/kernel/unprivileged_userns_clone
- fi
- $(which xhost) + &>/dev/zero
- sudo -nu slim-root DISPLAY=:0 \
- DBUS_SESSION_BUS_ADDRESS=unix:path=/run/dbus/system_bus_socket \
- /usr/share/slimjet/flashpeak-slimjet \
- --flag-switches-begin --enable-fast-unload \
- --disable-offline-auto-reload-visible-only \
- --enable-offline-auto-reload --enable-tcp-fastopen \
- --num-raster-threads=4 --disable-smooth-scrolling \
- --enable-features=PasswordExport --flag-switches-end $@ &
+if [[ $(id -u) -eq 0 ]]; then
+ $(which xhost) + &>/dev/zero
+ sudo -nu slim-root DISPLAY=:0 \
+ DBUS_SESSION_BUS_ADDRESS=unix:path=/run/dbus/system_bus_socket \
+ /usr/share/slimjet/flashpeak-slimjet \
+ --flag-switches-begin --enable-fast-unload \
+ --disable-offline-auto-reload-visible-only \
+ --enable-offline-auto-reload --enable-tcp-fastopen \
+ --num-raster-threads=4 --disable-smooth-scrolling \
+ --enable-features=PasswordExport --flag-switches-end $@ &
else
- if [[ `cat /proc/sys/kernel/unprivileged_userns_clone` -eq 0 ]]; then
- echo 1 > /proc/sys/kernel/unprivileged_userns_clone
- fi
- /usr/share/flashpeak-slimjet $@ &
+ /usr/share/flashpeak-slimjet $@ &
fi
wait $!
-exit $? \ No newline at end of file
+exit $?
diff --git a/slimjet-browser.install b/slimjet-browser.install
index 96d3620880b6..f1ed10e1741f 100644
--- a/slimjet-browser.install
+++ b/slimjet-browser.install
@@ -1,13 +1,20 @@
-#!/bin/sh
+#!/bin/bash
post_install() {
+ if [[ ! -d /etc/sysctl.d ]]; then
+ mkdir -m0755 /etc/sysctl.d &>/dev/zero
+ fi
+ echo "kernel.unprivileged_userns_clone = 1" >/etc/sysctl.d/slimjet_userns_sandbox.conf
+ chmod 0755 /etc/sysctl.d/slimjet_userns_sandbox.conf
+ sysctl -p /etc/sysctl.d/slimjet_userns_sandbox.conf
useradd -G root,dbus,wheel,http,network,video,audio \
- -m -k /dev/zero --comment 'SlimJet runtime' \
- -s /bin/sh slim-root || exit 1
- chown slim-root:root -R /home/slim-root || exit 1
- chown slim-root:root -R /usr/share/slimjet || exit 1
+ -m -k /dev/zero --comment 'SlimJet runtime' \
+ -s /bin/sh slim-root || exit 1
+ chown slim-root:root -R /home/slim-root || exit 1
+ chown slim-root:root -R /usr/share/slimjet || exit 1
}
post_remove() {
- userdel --force --remove slim-root || exit 1
- rm -rf /usr/share/slimjet &>/dev/zero
-} \ No newline at end of file
+ unlink /etc/sysctl.d/slimjet_userns_sandbox.conf
+ userdel --force --remove slim-root
+ rm -rf /usr/share/slimjet &>/dev/zero
+}