summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorergotamin2018-12-08 17:07:00 +0100
committerergotamin2018-12-08 17:07:00 +0100
commitb2f19f703c187dcf226880d7b113aef7b00127f8 (patch)
tree4bfd6f2ca36643b44f738ffd5d35c11d807b4acb
downloadaur-b2f19f703c187dcf226880d7b113aef7b00127f8.tar.gz
[committed on 08.12.2018 at 17:07:00] Initial commit...
-rw-r--r--.SRCINFO45
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD51
-rw-r--r--slimjet-browser.install13
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1046c1ccec8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = slimjet-browser
+ pkgdesc = A lightweight Browser based on Blink (**added: 'slim-root' sandbox-user)
+ pkgver = 21.0.4.0
+ pkgrel = 1
+ url = http://www.slimjet.com
+ install = slimjet-browser.install
+ arch = x86_64
+ license = custom:freeware
+ license = MIT
+ makedepends = pacman>=4.2.0
+ makedepends = imagemagick>7.0.0
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = flac
+ depends = gconf
+ depends = gtk2
+ depends = harfbuzz
+ depends = harfbuzz-icu
+ depends = hicolor-icon-theme
+ depends = xorg-xhost
+ depends = icu
+ depends = libpng
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = openssl
+ depends = nspr
+ depends = opus
+ depends = snappy
+ depends = speech-dispatcher
+ depends = ttf-font
+ depends = xdg-utils
+ optdepends = kdebase-kdialog: needed for file dialogs in KDE
+ optdepends = ttf-liberation: fix fonts for some PDFs
+ provides = slimjet-browser
+ replaces = slimjet
+ options = !emptydirs
+ options = !strip
+ source = slimjet-browser-21.0.4.0-x86_64.deb::https://www.slimjet.com/release/archive/21.0.4.0/slimjet_amd64.deb
+ source = LICENSE
+ sha256sums = 6aaffba334238429f92b5fe29d10c7799ffdb34d1ac94d2fa9e73981d8ac567b
+ sha256sums = fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e
+
+pkgname = slimjet-browser
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ab0d0bcdd61c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,3 @@
+ Slimjet Web Browser is released under the freeware license. It is free both for personal use and commerical use. It is free to be distributed over the internet and/or
+ through offline distribution channels as long as it is kept in its original form without any change. Bundling Slimjet with other software in another installer is strictly
+ prohibited.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66655188ff9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Marcel Bobolz <ergotamin.source at gmail dot com>
+# Contributor: visit ""
+pkgname=('slimjet-browser')
+_origname='slimjet'
+pkgver=21.0.4.0
+pkgrel=1
+pkgdesc="A lightweight Browser based on Blink (**added: 'slim-root' sandbox-user)"
+arch=('x86_64')
+url="http://www.slimjet.com"
+depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme' 'xorg-xhost'
+ 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'openssl' 'nspr' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
+optdepends=('kdebase-kdialog: needed for file dialogs in KDE' 'ttf-liberation: fix fonts for some PDFs')
+makedepends=('pacman>=4.2.0' 'imagemagick>7.0.0')
+options=('!emptydirs' '!strip')
+provides=('slimjet-browser')
+replaces=('slimjet')
+license=('custom:freeware' 'MIT')
+source=("${pkgname}-${pkgver}-${arch}.deb::https://www.${_origname}.com/release/archive/${pkgver}/${_origname}_amd64.deb"
+ "LICENSE")
+install='slimjet-browser.install'
+sha256sums=('6aaffba334238429f92b5fe29d10c7799ffdb34d1ac94d2fa9e73981d8ac567b'
+ 'fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e')
+
+package() {
+ rm -f 'control.tar.gz' 'debian-binary'
+ msg2 "Extracting data.tar.xz of ${pkgname}-${pkgver}-${arch}.deb ..."
+ bsdtar -xpf "data.tar.xz"
+ msg2 "Sanitizing extracted file-tree ..."
+ rm -f "usr/bin/flashpeak-slimjet"
+ rm -rf "usr/share/doc"
+ mkdir -p "usr/share/licenses/${pkgname}"
+ install "${srcdir}/LICENSE" "usr/share/licenses/${pkgname}"
+ convert "usr/share/pixmaps/slimjet.xpm" "usr/share/pixmaps/slimjet.png" &>/dev/zero
+ sed 's%^Exec=/usr/bin/flashpeak-slimjet%Exec=/usr/bin/slimjet-browser%g' -i "usr/share/applications/slimjet.desktop"
+ sed 's%^Icon=flashpeak-slimjet%Icon=slimjet%g' -i "usr/share/applications/slimjet.desktop"
+ mv "opt/slimjet" "usr/share/slimjet"
+ rm -rf "opt"
+ printf "#\!/bin/sh
+xhost + &>/dev/zero
+su - slim-root -c '#\!/bin/sh
+export FLASHPEAK=/usr/share/slimjet/flashpeak-slimjet
+export DISPLAY=:0'
+\${FLASHPEAK} \$@
+'
+" > "usr/bin/slimjet-browser"
+ chmod 0755 "usr/bin/slimjet-browser"
+ msg2 "Moving sanitized file-tree to package-directory ..."
+ mv --target-directory="${pkgdir}" usr
+ chmod -R 0755 "${pkgdir}/"
+ msg2 "Finished packaging !"
+}
diff --git a/slimjet-browser.install b/slimjet-browser.install
new file mode 100644
index 000000000000..8c7c2021d22c
--- /dev/null
+++ b/slimjet-browser.install
@@ -0,0 +1,13 @@
+#!/bin/sh
+post_install() {
+ mkdir -m0755 ${config}/.slim-root || exit 1
+ useradd -M -G wheel,http,audio,video,root,sys,mem,utmp --home=${HOME}/.slim-root -s /bin/sh slim-root || exit 1
+ chown slim-root:root -R /usr/share/slimjet || exit 1
+ setcap cap_setuid,cap_sys_chroot,cap_sys_admin+pei slimjet-sandbox || exit 1
+ chown root:root /usr/share/slimjet/slimjet-sandbox || exit 1
+ chmod 4755 /usr/share/slimjet/slimjet-sandbox || exit 1
+}
+
+post_remove() {
+ userdel --force --remove slim-root || exit 1
+} \ No newline at end of file