summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2018-12-18 22:24:40 -0500
committerTed Alff2018-12-18 22:24:40 -0500
commita3f9121df7c96bf78fab0ba97bff5780f663bdf8 (patch)
tree7d9563917a5bb60e9d6a73ee3079215bf8b22df7
parentdf46981c7c70855d3a37f1ed2f37624393160d12 (diff)
downloadaur-a3f9121df7c96bf78fab0ba97bff5780f663bdf8.tar.gz
Version bump 0.10
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--slingshot.patch49
-rw-r--r--slingshot.sh7
4 files changed, 17 insertions, 97 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54d1f2c3360c..a76b3be0b6ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Dec 19 03:24:15 UTC 2018
pkgbase = slingshot
pkgdesc = A 2D strategy game in the gravity fields of several planets
- pkgver = 0.8.1p
- pkgrel = 7
- url = http://slingshot.wikispot.org
+ pkgver = 0.10
+ pkgrel = 1
+ url = https://github.com/schuellerf/slingshot
arch = any
license = GPL
+ makedepends = python2-distutils-extra
depends = python2-pygame
- source = http://downloads.sourceforge.net/slingshot-game/Slingshot-0.8.1p-linux.tar.gz
- source = slingshot.sh
- source = slingshot.patch
- md5sums = cdfcf0c85dc7d1b203344c24f591e7b5
- md5sums = 38bb1952740a5780dda0b1ea32b933aa
- md5sums = acf36309734e5357a5a641ea6bc415cf
+ source = slingshot-0.10.tar.gz::https://github.com/schuellerf/slingshot/archive/0.10.tar.gz
+ sha256sums = 9b076414bc163aea764bbe1a9bd9377a1c160fc9804d19e1fec8e67beac53bb1
pkgname = slingshot
diff --git a/PKGBUILD b/PKGBUILD
index 2ae002227c10..0264952b6564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,42 +4,19 @@
# Contributor: Arkham <arkham at archlinux dot us>
pkgname=slingshot
-pkgver=0.8.1p
-pkgrel=7
+pkgver=0.10
+pkgrel=1
pkgdesc="A 2D strategy game in the gravity fields of several planets"
arch=('any')
-url="http://slingshot.wikispot.org"
+url="https://github.com/schuellerf/slingshot"
license=('GPL')
depends=('python2-pygame')
-source=(http://downloads.sourceforge.net/$pkgname-game/Slingshot-$pkgver-linux.tar.gz
- $pkgname.sh
- $pkgname.patch)
-md5sums=('cdfcf0c85dc7d1b203344c24f591e7b5'
- '38bb1952740a5780dda0b1ea32b933aa'
- 'acf36309734e5357a5a641ea6bc415cf')
-
-build() {
- cd "$srcdir"/Slingshot-$pkgver-linux
-
- tar -xzf "$pkgname"_files.tar.gz
-
- patch -Np1 -i "$srcdir"/$pkgname.patch
-}
+makedepends=('python2-distutils-extra')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/schuellerf/slingshot/archive/${pkgver}.tar.gz")
+sha256sums=('9b076414bc163aea764bbe1a9bd9377a1c160fc9804d19e1fec8e67beac53bb1')
package() {
- cd "$srcdir"/Slingshot-$pkgver-linux
-
- install -dm755 "$pkgdir"/usr/share/$pkgname/data/
-
- for file in "$pkgname"/*.py ; do
- install -Dm644 "$file" "$pkgdir"/usr/share/$pkgname/
- done
-
- for file in "$pkgname"/data/* ; do
- install -Dm644 "$file" "$pkgdir"/usr/share/$pkgname/data/
- done
-
- install -Dm644 readme "$pkgdir"/usr/share/doc/$pkgname/readme
- install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
- install -Dm755 "$srcdir"/$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ cd "${pkgname}-${pkgver}"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" \
+ --no-compile -O0
}
diff --git a/slingshot.patch b/slingshot.patch
deleted file mode 100644
index 51e0a8f0030c..000000000000
--- a/slingshot.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -ur Slingshot-0.8.1p-linux.orig/slingshot/planet.py Slingshot-0.8.1p-linux/slingshot/planet.py
---- Slingshot-0.8.1p-linux.orig/slingshot/planet.py 2007-06-22 12:52:33.000000000 +0100
-+++ Slingshot-0.8.1p-linux/slingshot/planet.py 2012-08-23 22:39:42.366476664 +0100
-@@ -56,7 +56,7 @@
- if d < (self.r + p.get_radius()) * 1.5 + 0.1 * (self.mass + p.get_mass()):
- positioned = False
-
-- s = round(2 * self.r / 0.96)
-+ s = int(round(2 * self.r / 0.96))
- self.orig = pygame.transform.scale(self.image, (s, s))
-
- self.image = self.orig
-diff -ur Slingshot-0.8.1p-linux.orig/slingshot/player.py Slingshot-0.8.1p-linux/slingshot/player.py
---- Slingshot-0.8.1p-linux.orig/slingshot/player.py 2007-07-13 19:27:18.000000000 +0100
-+++ Slingshot-0.8.1p-linux/slingshot/player.py 2012-08-23 22:39:48.449904152 +0100
-@@ -237,8 +237,8 @@
- y = round(pos[1] - self.rect.topleft[1])
- if x <= 1 or y <= 1:
- return False
-- x = x - 1
-- y = y - 1
-+ x = int(x - 1)
-+ y = int(y - 1)
- if not self.image.get_at((x,y)) == (0,0,0,0):
- self.shot = True
- return True
-diff -ur Slingshot-0.8.1p-linux.orig/slingshot/slingshot.py Slingshot-0.8.1p-linux/slingshot/slingshot.py
---- Slingshot-0.8.1p-linux.orig/slingshot/slingshot.py 2007-07-13 20:57:05.000000000 +0100
-+++ Slingshot-0.8.1p-linux/slingshot/slingshot.py 2012-08-23 22:40:05.066827632 +0100
-@@ -442,7 +442,7 @@
- tmp = tmp.convert_alpha()
- rect = tmp.get_rect()
- s = (100 - self.show_round) * rect.h / 25
-- tmp = pygame.transform.scale(tmp, (rect.w / rect.h * s, s ))
-+ tmp = pygame.transform.scale(tmp, (int(rect.w / rect.h * s), int(s) ))
- rect = tmp.get_rect()
- rect.center = (399,299)
- self.screen.blit(tmp, rect.topleft)
-diff -ur Slingshot-0.8.1p-linux.orig/slingshot.desktop Slingshot-0.8.1p-linux/slingshot.desktop
---- Slingshot-0.8.1p-linux.orig/slingshot.desktop 2007-06-23 21:45:09.000000000 +0100
-+++ Slingshot-0.8.1p-linux/slingshot.desktop 2012-08-23 22:46:50.806435681 +0100
-@@ -4,6 +4,6 @@
- Comment=A Newtonian Strategy Game
- Exec=slingshot
- Categories=Application;Game;
--Icon=/opt/slingshot/data/icon64x64.png
-+Icon=/usr/share/slingshot/data/icon64x64.png
- Terminal=false
- Type=Application
diff --git a/slingshot.sh b/slingshot.sh
deleted file mode 100644
index 73fe57409472..000000000000
--- a/slingshot.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-cd /usr/share/slingshot
-
-python2 slingshot.py
-
-exit