summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHamletDuFromage (github workflow https://github.com/HamletDuFromage/slippi-online-git-PKGBUILD)2023-05-30 15:35:41 +0000
committerHamletDuFromage (github workflow https://github.com/HamletDuFromage/slippi-online-git-PKGBUILD)2023-05-30 15:35:41 +0000
commit8e1b225792db3778c4772ea7947f4cb2d8205da4 (patch)
tree0b981d9ed6e556d8a5b2706afd6dcb1292d4a930
parentca9b3fc011d35e222163ee715b930d9e241336e3 (diff)
downloadaur-8e1b225792db3778c4772ea7947f4cb2d8205da4.tar.gz
automatic: updated PKGBUILD (AUR)
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb5e99dce777..2ef5f04c844b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase")
_tagname='v3.0.4'
pkgver='v3.0.4.r0.g0b4ba1fd8'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Super Smash Bros. Melee rollback netcode'
_pkgdescappend=' - git version'
arch=('x86_64')
@@ -21,8 +21,14 @@ depends=(
)
makedepends=('cmake' 'git' 'qt5-base')
optdepends=('pulseaudio: PulseAudio backend')
-source=("$pkgname::git+https://github.com/project-slippi/Ishiiruka.git#tag=$_tagname")
-sha256sums=('SKIP')
+source=(
+ "$pkgname::git+https://github.com/project-slippi/Ishiiruka.git#tag=$_tagname"
+ "$pkgname-mbedtls2.diff::https://github.com/project-slippi/Ishiiruka/pull/384.diff"
+)
+sha256sums=(
+ 'SKIP'
+ 'a82d73418931e0eb5cf252e557b040e750917197131ee43dcf7df550a8f8d83c'
+)
_sourcedirectory="$pkgbase"
_dolphinemu="dolphin-emu"
@@ -36,6 +42,8 @@ pkgver() {
build() {
cd "$_sourcedirectory/"
+ patch --forward -p1 < "$srcdir/$pkgname-mbedtls2.diff"
+
CMAKE_FLAGS='-DLINUX_LOCAL_DEV=true'
# Move into the build directory, run CMake, and compile the project