summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2015-10-02 14:49:21 -0400
committerDaniel M. Capella2015-10-02 14:49:21 -0400
commit9b8d5f82c76c29aded31ebd900ec42422422c9d8 (patch)
tree58a6aabc6523131bfc0db38e1e4e60714da3d317
downloadaur-9b8d5f82c76c29aded31ebd900ec42422422c9d8.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6a23af0b2e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sloc
+ pkgdesc = Simply counts source lines of code
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = http://bytbox.net/hacks/sloc
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = go
+ optdepends = perl-datetime
+ optdepends = perl-json
+ optdepends = perl-switch
+ optdepends = gnuplot
+ source = sloc::git+http://git.bytbox.net/sloc/#tag=v0.3.1
+ sha256sums = SKIP
+
+pkgname = sloc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fd3e3817da0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel M. Capella <polycitizen@gmail.com>
+# Contributor: Scott Lawrence <bytbox@gmail.com>
+
+pkgname=sloc
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Simply counts source lines of code"
+arch=('i686' 'x86_64')
+url='http://bytbox.net/hacks/sloc'
+license=('MIT')
+depends=('go')
+optdepends=('perl-datetime' 'perl-json' 'perl-switch' 'gnuplot')
+makedepends=(git)
+source=("sloc::git+http://git.bytbox.net/sloc/#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd sloc
+ ./gen-man.sh
+
+ cd sloc
+ go build -o sloc
+}
+
+package() {
+ cd sloc
+ install -D -m755 sloc/sloc "$pkgdir"/usr/bin/sloc
+ install -D -m755 reposloc "$pkgdir"/usr/bin/reposloc
+ install -D -m644 reposloc.1 "$pkgdir"/usr/share/man/man1/reposloc.1
+}
+
+# vim:set ts=2 sw=2 et: