summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorymber2018-11-24 12:38:54 +0000
committerymber2018-11-24 12:38:54 +0000
commit853201a6d074618510465408d49e62e71b6cd50f (patch)
tree7caf0e2bfba66ab70a6eafb8e8d0ed1235b1ea8d
downloadaur-853201a6d074618510465408d49e62e71b6cd50f.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
-rw-r--r--config.h12
-rw-r--r--solarized.patch18
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afa957e182a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = slock-solarized-dark
+ pkgdesc = Simple X display locker.
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://tools.suckless.org/slock/
+ arch = x86_64
+ license = MIT
+ depends = libxrandr
+ provides = slock
+ source = https://dl.suckless.org/tools/slock-1.4.tar.gz
+ source = config.h
+ source = solarized.patch
+ sha256sums = b53849dbc60109a987d7a49b8da197305c29307fd74c12dc18af0d3044392e6a
+ sha256sums = fd86100f2dd81fc41a4b4cb2a54a6076d393b08ab43d98b5e5ba7bbf1218fe71
+ sha256sums = 1d9b1dad24cd6bf51f7ce39b855634dcbb301ae22f79ddcf44fa09fad8dc4e79
+
+pkgname = slock-solarized-dark
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..764580fc5af7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Matthew Taylor <mtaylor1252dev@gmail.com>
+
+pkgname=slock-solarized-dark
+_pkgname=slock
+pkgver=1.4
+pkgrel=1
+pkgdesc="Simple X display locker."
+arch=("x86_64")
+url="https://tools.suckless.org/slock/"
+license=("MIT")
+depends=("libxrandr")
+provides=("slock")
+source=(https://dl.suckless.org/tools/$_pkgname-$pkgver.tar.gz
+ config.h
+ solarized.patch)
+sha256sums=("b53849dbc60109a987d7a49b8da197305c29307fd74c12dc18af0d3044392e6a"
+ "fd86100f2dd81fc41a4b4cb2a54a6076d393b08ab43d98b5e5ba7bbf1218fe71"
+ "1d9b1dad24cd6bf51f7ce39b855634dcbb301ae22f79ddcf44fa09fad8dc4e79")
+
+prepare() {
+ cd $srcdir/$_pkgname-$pkgver
+ cp $srcdir/config.h config.h
+ patch -p0 -i $srcdir/solarized.patch
+}
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ make PREFIX=/usr DESTDIR=$pkgdir install
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+ install -Dm644 README $pkgdir/usr/share/doc/$_pkgname/README
+}
+
diff --git a/config.h b/config.h
new file mode 100644
index 000000000000..9855e2117e71
--- /dev/null
+++ b/config.h
@@ -0,0 +1,12 @@
+/* user and group to drop privileges to */
+static const char *user = "nobody";
+static const char *group = "nogroup";
+
+static const char *colorname[NUMCOLS] = {
+ [INIT] = "black", /* after initialization */
+ [INPUT] = "#005577", /* during input */
+ [FAILED] = "#CC3333", /* wrong password */
+};
+
+/* treat a cleared input like a wrong password (color) */
+static const int failonclear = 1;
diff --git a/solarized.patch b/solarized.patch
new file mode 100644
index 000000000000..508b277bcf04
--- /dev/null
+++ b/solarized.patch
@@ -0,0 +1,18 @@
+--- config.def.h 2016-11-20 00:31:23.000000000 +0000
++++ config.h 2018-11-24 12:02:40.238994112 +0000
+@@ -1,11 +1,11 @@
+ /* user and group to drop privileges to */
+ static const char *user = "nobody";
+-static const char *group = "nogroup";
++static const char *group = "nobody";
+
+ static const char *colorname[NUMCOLS] = {
+- [INIT] = "black", /* after initialization */
+- [INPUT] = "#005577", /* during input */
+- [FAILED] = "#CC3333", /* wrong password */
++ [INIT] = "#002b36", /* after initialization */
++ [INPUT] = "#268bd2", /* during input */
++ [FAILED] = "#cb4b16", /* wrong password */
+ };
+
+ /* treat a cleared input like a wrong password (color) */