summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndřej Hruška2015-06-14 21:21:04 +0200
committerOndřej Hruška2015-06-14 21:21:04 +0200
commit7d495f3c07769faa56a7afa19169826b16f7ad3f (patch)
treeb9dc46610e7687d30e3e73237f97f2f2108bd6e2
downloadaur-7d495f3c07769faa56a7afa19169826b16f7ad3f.tar.gz
Source import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..997594dbf1dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = slock-xtra-git
+ pkgdesc = Simple X display locker, with adjustable color and more intuitive behavior.
+ pkgver = 20141117.191388c
+ pkgrel = 1
+ url = https://github.com/MightyPork/slock
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = libxext
+ makedepends = git
+ depends = libx11
+ provides = slock
+ conflicts = slock
+ source = git://github.com/MightyPork/slock
+ sha1sums = SKIP
+
+pkgname = slock-xtra-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b5ab28530ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ondřej Hruška <ondra@ondrovo.com>
+# Original author: Anselm R Garbe <anselm@garbe.us>
+
+pkgname=slock-xtra-git
+_pkgname=slock
+pkgver=20141117.191388c
+pkgrel=1
+pkgdesc='Simple X display locker, with adjustable color and more intuitive behavior.'
+url='https://github.com/MightyPork/slock'
+arch=('i686' 'x86_64' 'armv7h')
+license=('MIT')
+depends=('libx11')
+conflicts=('slock')
+makedepends=('libxext' 'git')
+source=('git://github.com/MightyPork/slock')
+sha1sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags | sed "s|-|.|g"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}