summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Michaelis2022-03-23 22:24:48 +0100
committerOlivier Michaelis2022-03-23 22:24:48 +0100
commit49a8f7c38126e49343f3315625c1436dedac9651 (patch)
treed60e78945b447eaad8ab24e81391dbc74b0f980c
downloadaur-49a8f7c38126e49343f3315625c1436dedac9651.tar.gz
Initial upload: sloth-bin 0.10.0-1
Signed-off-by: Olivier Michaelis <38879457+oliviermichaelis@users.noreply.github.com>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85281a1ae8b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sloth-bin
+ pkgdesc = Easy and simple Prometheus SLO (service level objectives) generator
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/slok/sloth
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = Apache
+ source_x86_64 = sloth-x86_64::https://github.com/slok/sloth/releases/download/v0.10.0/sloth-linux-amd64
+ md5sums_x86_64 = a64522dc1c3925e026d4f73d4d1db470
+ source_aarch64 = sloth-aarch64::https://github.com/slok/sloth/releases/download/v0.10.0/sloth-linux-arm64
+ md5sums_aarch64 = 8d6c4295db79fd304beadf399bd3173a
+ source_armv7h = sloth-armv7h::https://github.com/slok/sloth/releases/download/v0.10.0/sloth-linux-arm-v7
+ md5sums_armv7h = 797f069e9ea8556b49447d17a524f22d
+
+pkgname = sloth-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94e70cbbdf80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Olivier Michaelis <michaelis.olivier [at] gmail [dot] com>
+
+pkgname=sloth-bin
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Easy and simple Prometheus SLO (service level objectives) generator"
+arch=('x86_64' 'aarch64' 'armv7h')
+url="https://github.com/slok/sloth"
+license=('Apache')
+source_x86_64=(sloth-x86_64::https://github.com/slok/sloth/releases/download/v$pkgver/sloth-linux-amd64)
+source_aarch64=(sloth-aarch64::https://github.com/slok/sloth/releases/download/v${pkgver}/sloth-linux-arm64)
+source_armv7h=(sloth-armv7h::https://github.com/slok/sloth/releases/download/v$pkgver/sloth-linux-arm-v7)
+md5sums_x86_64=('a64522dc1c3925e026d4f73d4d1db470')
+md5sums_aarch64=('8d6c4295db79fd304beadf399bd3173a')
+md5sums_armv7h=('797f069e9ea8556b49447d17a524f22d')
+
+package() {
+ install -Dm755 sloth-${arch} "$pkgdir/usr/bin/sloth"
+}