summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2015-08-03 15:49:20 +0200
committerevorster2015-08-03 15:49:20 +0200
commit94638f7577537e42133b8a53720918245f839ccb (patch)
treedef6a8343e95e84be178711ef18cf8654799553a
downloadaur-94638f7577537e42133b8a53720918245f839ccb.tar.gz
Package imported by apac-migrate
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
-rw-r--r--slowmovideo-git.install11
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..326175a9839b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = slowmovideo-git
+ pkgdesc = Video slow motion effect via interpolation
+ pkgver = 20150423
+ pkgrel = 1
+ url = http://slowmovideo.granjow.net/index.html
+ install = slowmovideo-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = glew
+ depends = opencv
+ depends = qt5-script
+ depends = xdg-utils
+ depends = desktop-file-utils
+ provides = slowmovideo
+ conflicts = slowmovideo
+ source = git+https://github.com/slowmoVideo/slowmoVideo.git
+ md5sums = SKIP
+
+pkgname = slowmovideo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe0cdd0a7232
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: evorster <evorster@gmail.com>
+# Contributor: ZKenJ <zkenjm@gmail.com>
+# Contributor: Cilyan
+# Contributor: Dan Serban
+# Contributor: sjewo
+# Contributor: Theo Nicolau
+
+
+pkgname=slowmovideo-git
+pkgver=20150423
+pkgrel=1
+pkgdesc="Video slow motion effect via interpolation"
+arch=('i686' 'x86_64')
+url="http://slowmovideo.granjow.net/index.html"
+license=('GPL')
+depends=('glew' 'opencv' 'qt5-script' 'xdg-utils' 'desktop-file-utils')
+makedepends=('cmake' 'git')
+provides=('slowmovideo')
+conflicts=('slowmovideo')
+source=('git+https://github.com/slowmoVideo/slowmoVideo.git')
+md5sums=('SKIP')
+install=$pkgname.install
+
+#prepare(){
+#cd ${srcdir}/slowmoVideo
+#patch -p1 -i ../../${pkgname}.patch
+#}
+
+pkgver() {
+ cd "${srcdir}"/slowmoVideo
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+build() {
+ cd "${srcdir}/slowmoVideo"
+ mkdir build && cd build
+ export LDFLAGS="-lX11 ${LDFLAGS}"
+ cmake -DUSE_QTKIT=FALSE -DENABLE_TESTS=FALSE -DCMAKE_INSTALL_PREFIX=/usr ../src
+ make
+}
+
+package() {
+ cd "${srcdir}/slowmoVideo/build"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/slowmovideo-git.install b/slowmovideo-git.install
new file mode 100644
index 000000000000..4c74affdff93
--- /dev/null
+++ b/slowmovideo-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q &>/dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}