summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCp Dong2024-02-22 22:59:23 +0800
committerCp Dong2024-02-22 22:59:23 +0800
commit76a0519f3136ef36713a8413130a7e33bcf10a15 (patch)
tree10bc2b4208dcc8138e22bbbe0458f7c5b9ec120d
downloadaur-76a0519f3136ef36713a8413130a7e33bcf10a15.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
-rw-r--r--config.h69
3 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..501568074619
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = slstatus
+ pkgdesc = A status monitor for window managers that use WM_NAME or stdin to fill the status bar
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://tools.suckless.org/slstatus/
+ arch = any
+ license = ISC
+ depends = libx11
+ conflicts = slstatus-git
+ source = https://dl.suckless.org/tools/slstatus-1.0.tar.gz
+ source = config.h
+ sha256sums = 6d6d0a16c08dd9d211172c30c4720701267a3f40cdc938db3f386f6a2b6cff54
+ sha256sums = SKIP
+
+pkgname = slstatus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02e12483b1e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Cp Dong <cp-dong at outlook dot com>
+
+pkgname=slstatus
+pkgver=1.0
+pkgrel=1
+pkgdesc='A status monitor for window managers that use WM_NAME or stdin to fill the status bar'
+arch=(any)
+url='http://tools.suckless.org/slstatus/'
+depends=('libx11')
+conflicts=('slstatus-git')
+license=('ISC')
+source=('https://dl.suckless.org/tools/slstatus-1.0.tar.gz'
+ 'config.h')
+sha256sums=('6d6d0a16c08dd9d211172c30c4720701267a3f40cdc938db3f386f6a2b6cff54'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ if [[ -f "$srcdir/config.h" ]]; then
+ cp -fv "$srcdir/config.h" config.h
+ fi
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make X11INC='/usr/include/X11' X11LIB='/usr/lib/X11'
+}
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX='/usr' DESTDIR="${pkgdir}" install
+}
diff --git a/config.h b/config.h
new file mode 100644
index 000000000000..d805331c85e5
--- /dev/null
+++ b/config.h
@@ -0,0 +1,69 @@
+/* See LICENSE file for copyright and license details. */
+
+/* interval between updates (in ms) */
+const unsigned int interval = 1000;
+
+/* text to show if no value can be retrieved */
+static const char unknown_str[] = "n/a";
+
+/* maximum output string length */
+#define MAXLEN 2048
+
+/*
+ * function description argument (example)
+ *
+ * battery_perc battery percentage battery name (BAT0)
+ * NULL on OpenBSD/FreeBSD
+ * battery_remaining battery remaining HH:MM battery name (BAT0)
+ * NULL on OpenBSD/FreeBSD
+ * battery_state battery charging state battery name (BAT0)
+ * NULL on OpenBSD/FreeBSD
+ * cat read arbitrary file path
+ * cpu_freq cpu frequency in MHz NULL
+ * cpu_perc cpu usage in percent NULL
+ * datetime date and time format string (%F %T)
+ * disk_free free disk space in GB mountpoint path (/)
+ * disk_perc disk usage in percent mountpoint path (/)
+ * disk_total total disk space in GB mountpoint path (/)
+ * disk_used used disk space in GB mountpoint path (/)
+ * entropy available entropy NULL
+ * gid GID of current user NULL
+ * hostname hostname NULL
+ * ipv4 IPv4 address interface name (eth0)
+ * ipv6 IPv6 address interface name (eth0)
+ * kernel_release `uname -r` NULL
+ * keyboard_indicators caps/num lock indicators format string (c?n?)
+ * see keyboard_indicators.c
+ * keymap layout (variant) of current NULL
+ * keymap
+ * load_avg load average NULL
+ * netspeed_rx receive network speed interface name (wlan0)
+ * netspeed_tx transfer network speed interface name (wlan0)
+ * num_files number of files in a directory path
+ * (/home/foo/Inbox/cur)
+ * ram_free free memory in GB NULL
+ * ram_perc memory usage in percent NULL
+ * ram_total total memory size in GB NULL
+ * ram_used used memory in GB NULL
+ * run_command custom shell command command (echo foo)
+ * swap_free free swap in GB NULL
+ * swap_perc swap usage in percent NULL
+ * swap_total total swap size in GB NULL
+ * swap_used used swap in GB NULL
+ * temp temperature in degree celsius sensor file
+ * (/sys/class/thermal/...)
+ * NULL on OpenBSD
+ * thermal zone on FreeBSD
+ * (tz0, tz1, etc.)
+ * uid UID of current user NULL
+ * uptime system uptime NULL
+ * username username of current user NULL
+ * vol_perc OSS/ALSA volume in percent mixer file (/dev/mixer)
+ * NULL on OpenBSD/FreeBSD
+ * wifi_essid WiFi ESSID interface name (wlan0)
+ * wifi_perc WiFi signal in percent interface name (wlan0)
+ */
+static const struct arg args[] = {
+ /* function format argument */
+ { datetime, "%s", "%F %T" },
+};