summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-04-18 17:39:24 +0200
committerGordian Edenhofer2016-04-18 17:39:24 +0200
commitb97151504fad1ed351c64c130ef53a02ad1017a0 (patch)
tree92ced2ee909bd1a106cf6c987ddca106a96e3b43
parentcc42434719c39c9e6a31fd77d605ac142b9dba28 (diff)
downloadaur-b97151504fad1ed351c64c130ef53a02ad1017a0.tar.gz
Upgpkg: 16.05.0_0pre2-2
Set some more configure flags to compile more libraries into the final package in the hope that users do not have to recompile after installing a new optdep. Trigger autogen.sh for an up-to-date ./configure script. Escape possible spaces in variables.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
-rw-r--r--slurm-llnl-dev.install5
3 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 105d8222af3..8a66bbe7023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = slurm-llnl-dev
pkgdesc = Simple Linux Utility for Resource Management (development version)
pkgver = 16.05.0_0pre2
- pkgrel = 1
+ pkgrel = 2
url = http://www.schedmd.com
install = slurm-llnl-dev.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0d744caf4c7..bab235c8ab9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgver=16.05.0_0pre2
# Hyphens (-) are prohibited however they are used by the package author
# therefore it is necessary to invoke ${pkgver} like ${pkgver//_/-}
# this will substituet any udnerscores (_) with hyphens
-pkgrel=1
+pkgrel=2
pkgdesc="Simple Linux Utility for Resource Management (development version)"
arch=('i686' 'x86_64')
url="http://www.schedmd.com"
@@ -32,7 +32,7 @@ makedepends=('python')
provides=('slurm-llnl')
conflicts=('slurm-llnl' 'slurm-llnl-git')
backup=('etc/default/slurm-llnl')
-install=${pkgname}.install
+install="${pkgname}.install"
source=("slurm-tmpfiles.conf"
"slurm-llnl-default-conf"
"slurmctld.service"
@@ -56,11 +56,19 @@ build() {
#
# Read http://slurm.schedmd.com/quickstart_admin.html for more information
+ ./autogen.sh
./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/slurm-llnl \
- --localstatedir=/var
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/slurm-llnl \
+ --localstatedir=/var \
+ --enable-pam \
+ --with-proctrack \
+ --with-hdf5 \
+ --with-hwloc \
+ --with-rrdtool \
+ --with-ssl \
+ --with-munge
make
}
diff --git a/slurm-llnl-dev.install b/slurm-llnl-dev.install
index 17a84b71daf..77a897dd2db 100644
--- a/slurm-llnl-dev.install
+++ b/slurm-llnl-dev.install
@@ -21,16 +21,11 @@ post_install() {
echo -e "\e[34;1m==>\e[39;1m NOTE: You have to create a slurm configuration-file in /etc/slurm-llnl/ \e[0m"
echo -e "\e[34;1m==>\e[39;1m prior to starting any slurm daemons. \e[0m"
- echo -e "\e[34;1m==>\e[39;1m NOTE: In order for new optional dependencies to be taken into account \e[0m"
- echo -e "\e[34;1m==>\e[39;1m slurm-llnl has to be recompiled. \e[0m"
}
## arg 1: the new package version
## arg 2: the old package version
post_upgrade() {
- echo -e "\e[34;1m==>\e[39;1m NOTE: In order for new optional dependencies to be taken into account \e[0m"
- echo -e "\e[34;1m==>\e[39;1m slurm-llnl has to be recompiled. \e[0m"
-
# THIS HAS TO BE REMOVED ONEDAY - TODO
if [ -f /etc/slurm/slurm.conf ]; then
mv /etc/slurm/* /etc/slurm-llnl/