summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorСтрахиња Радић2024-03-12 11:20:17 +0100
committerСтрахиња Радић2024-03-12 11:20:17 +0100
commit34bb80d4f11b7d3b56c3159dca40034248ac74b9 (patch)
tree57e60271c797a14dfff13ca711f1fcf66cd29049
parent22a5f765cfc19aadf643f9e3b8bea4f327a67a7f (diff)
downloadaur-34bb80d4f11b7d3b56c3159dca40034248ac74b9.tar.gz
Update to 0.9.5
Signed-off-by: Страхиња Радић <contact@strahinja.org>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 304c80ef8faa..f70af5ff2a55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = slweb
pkgdesc = Simple static website generator
- pkgver = 0.9.4
- pkgrel = 2
+ pkgver = 0.9.5
+ pkgrel = 1
url = https://strahinja.srht.site/slweb
arch = x86_64
license = GPL3
optdepends = katex: For math mode
optdepends = git: For {git-log}
optdepends = imagemagick: For img tag attributes
- source = slweb-0.9.4.tar.gz::https://git.sr.ht/~strahinja/slweb/archive/v0.9.4.tar.gz
- md5sums = 911e6746a510c528c18af38245ac04ec
+ source = slweb-0.9.5.tar.gz::https://git.sr.ht/~strahinja/slweb/archive/v0.9.5.tar.gz
+ md5sums = 5cd6182801c007c3b1b012d048aa4974
pkgname = slweb
diff --git a/PKGBUILD b/PKGBUILD
index 8ce29010bf24..2cb82a8b1d14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: Strahinya Radich <contact@strahinja.org>
pkgname=slweb
-pkgver=0.9.4
-pkgrel=2
+pkgver=0.9.5
+pkgrel=1
pkgdesc="Simple static website generator"
arch=('x86_64')
url="https://strahinja.srht.site/slweb"
license=('GPL3')
source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~strahinja/slweb/archive/v$pkgver.tar.gz")
-md5sums=('911e6746a510c528c18af38245ac04ec')
+md5sums=('5cd6182801c007c3b1b012d048aa4974')
optdepends=(
'katex: For math mode'
'git: For {git-log}'
'imagemagick: For img tag attributes'
)
+build() {
+ cd $pkgname-v$pkgver
+ FALLBACKVER=$pkgver-$pkgrel PREFIX="$pkgdir/usr" make -e all
+}
+
package() {
cd $pkgname-v$pkgver
FALLBACKVER=$pkgver-$pkgrel PREFIX="$pkgdir/usr" make -e install