summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbemxio2024-06-17 17:22:24 +0200
committerbemxio2024-06-17 17:22:24 +0200
commit7c1dea1f19b5dd9017085f09cb753773582f5cb5 (patch)
treee9603ea726f2fb3eb59f70cecac892d1a72c20c2
parent682ef55218efc0ff70673aaa7fb9a8a907651baa (diff)
downloadaur-7c1dea1f19b5dd9017085f09cb753773582f5cb5.tar.gz
include other necessary directories in the package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a38d40700a9b..200698e11036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sm64coopdx-git
pkgdesc = Fork of Super Mario 64 Co-op with more features, customizability and power to the Lua API
pkgver = r3689.30ccad3
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://sm64coopdx.com/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a5d6341608e7..dc5133363512 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Fork of Super Mario 64 Co-op with more features, customizability and po
_region="us" # change this (as well as the 2nd checksum in line 28) if you want to use a different ROM
pkgver=r3689.30ccad3
-pkgrel=2
+pkgrel=3
epoch=1
arch=(x86_64 i686 pentium4 aarch64 armv7h)
@@ -62,11 +62,16 @@ package() {
# move to the build directory
cd "sm64coopdx/build/${_region}_pc"
- # copy the main executable and libraries
+ # copy the main executable
install -Dm755 sm64coopdx "${pkgdir}/usr/share/sm64coopdx/sm64coopdx"
- find . \
- -type f -name "*.so" \
- -exec install -Dm755 {} "${pkgdir}/usr/lib/sm64coopdx/{}" \;
+
+ # copy the shared libraries
+ find . -type f -name "*.so" -exec install -Dm755 {} "${pkgdir}/usr/lib/sm64coopdx/{}" \;
+
+ # copy the other directories
+ find lang -type f -exec install -Dm644 {} "${pkgdir}/usr/share/sm64coopdx/{}" \;
+ find dynos -type f -exec install -Dm644 {} "${pkgdir}/usr/share/sm64coopdx/{}" \;
+ find mods -type f -exec install -Dm644 {} "${pkgdir}/usr/share/sm64coopdx/{}" \;
# copy the script
install -Dm755 "${srcdir}/sm64coopdx.sh" "${pkgdir}/usr/bin/sm64coopdx"