summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpacingBat32020-08-31 19:59:36 +0200
committerSpacingBat32020-08-31 19:59:36 +0200
commit75468acbcba32faaf57bbaaa6d24bbc804c98d9d (patch)
treea2329f2a85aa12c31a0afc6a2cdb02353f08b5d9
parent05385eb707f1c63090357c7401b65c9cb19d1f59 (diff)
downloadaur-75468acbcba32faaf57bbaaa6d24bbc804c98d9d.tar.gz
PKGBUILD Fix
Fixed a bug when patch wasn't applied after doing an update.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3da80e2d9679..2e03997c0d6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sm64ex-nightly-git
pkgdesc = Nightly branch of sm64ex with 60fps patch. PKGBUILD based on sm64pc-git.
- pkgver = r563.417d59e7
+ pkgver = r573.dd0e86db
pkgrel = 1
url = https://github.com/sm64pc/sm64ex
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index edce3c6e865f..bbad56efcd5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Hekuran https://github.com/narukeh
pkgname=sm64ex-nightly-git
-pkgver=r563.417d59e7
+pkgver=r573.dd0e86db
pkgrel=1
pkgdesc='Nightly branch of sm64ex with 60fps patch. PKGBUILD based on sm64pc-git.'
arch=('any')
@@ -23,24 +23,19 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$_gitname"
- cp "../../baserom.${_region}.z64" . || {
- printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
- printf "\\n%s\\n%s\\n\\n" \
- "NO ROM FOUND! Copy your sm64 ROM to \"$(realpath ../../)\" and rename it to \"baserom.${_region}.z64\"." \
- "The default ROM region is US. You have to edit the PKGBUILD if you would like to use a JP or EU version."
- printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
- }
-
- # Makes sure your path hasn't been changed since then:
- cd "$srcdir/$_gitname"
-
- # Patches the 60fps to the game (comment to disable):
- patch -p1 < "./enhancements/60fps_ex.patch"
+ cd "$srcdir/$_gitname"
+ cp "../../baserom.${_region}.z64" . || {
+ printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
+ printf "\\n%s\\n%s\\n\\n" \
+ "NO ROM FOUND! Copy your sm64 ROM to \"$(realpath ../../)\" and rename it to \"baserom.${_region}.z64\"." \
+ "The default ROM region is US. You have to edit the PKGBUILD if you would like to use a JP or EU version."
+ printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
+ }
}
build() {
cd "$srcdir/$_gitname"
+ patch -p1 < "./enhancements/60fps_ex.patch"
make VERSION=$_region BETTERCAMERA=1 ${MAKEFLAGS:--j$(nproc)}
}