summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSilvan Jegen2018-05-04 14:15:47 +0200
committerSilvan Jegen2018-05-04 14:25:23 +0200
commit035cf3ff6b1e4682353f0bcca8dce23903bf68b0 (patch)
treeb88a9e2643ceff274ce182df43780dca0c86c0ed
downloadaur-035cf3ff6b1e4682353f0bcca8dce23903bf68b0.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD32
-rwxr-xr-xsmallpdf2
-rw-r--r--smallpdf-desktop.desktop8
-rw-r--r--smallpdf-desktop.install8
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d13978a3de66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = smallpdf-desktop
+ pkgdesc = Smallpdf desktop reader and converter
+ pkgver = 1.9.1
+ pkgrel = 1
+ url = https://smallpdf.com/
+ install = smallpdf-desktop.install
+ arch = x86_64
+ license = custom
+ depends = gconf
+ depends = gtk3
+ depends = cairo
+ depends = pango
+ depends = dbus
+ depends = xorg-server
+ depends = c-ares
+ depends = ffmpeg
+ depends = http-parser
+ depends = libevent
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ provides = smallpdf-desktop
+ conflicts = smallpdf-desktop
+ source = https://download.smallpdf.com/desktop/linux/package-linux.tar.gz
+ source = smallpdf-desktop.desktop
+ source = smallpdf
+ sha256sums = bc50e95da1ada3495f59dc6c7d824a6ca6f446c24271a081b3b8d45cf1fda163
+ sha256sums = a56b2da40fec921ee2cbad55c3767fdba20af8055082c611a4ce2ab29fed3096
+ sha256sums = 9d3719ee5bf53a6bab73886ade14253a2055ba312804625354a8009509900050
+
+pkgname = smallpdf-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31188cc7adc0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Silvan <silvan@smallpdf.com>
+# Contributor: Max <max@smallpdf.com>
+
+pkgname=smallpdf-desktop
+pkgver=1.9.1
+pkgrel=1
+pkgdesc='Smallpdf desktop reader and converter'
+arch=(x86_64)
+url='https://smallpdf.com/'
+license=('custom')
+depends=('gconf' 'gtk3' 'cairo' 'pango' 'dbus' 'xorg-server'
+ 'c-ares' 'ffmpeg' 'http-parser' 'libevent' 'libxss'
+ 'minizip' 'nss' 're2')
+makedepends=()
+provides=('smallpdf-desktop')
+conflicts=('smallpdf-desktop')
+install='smallpdf-desktop.install'
+source=('https://download.smallpdf.com/desktop/linux/package-linux.tar.gz'
+ 'smallpdf-desktop.desktop'
+ 'smallpdf')
+sha256sums=('bc50e95da1ada3495f59dc6c7d824a6ca6f446c24271a081b3b8d45cf1fda163'
+ 'a56b2da40fec921ee2cbad55c3767fdba20af8055082c611a4ce2ab29fed3096'
+ '9d3719ee5bf53a6bab73886ade14253a2055ba312804625354a8009509900050')
+
+package() {
+ install -dm755 ${pkgdir}/opt/smallpdf-desktop
+ install -dm755 ${pkgdir}/usr/bin
+
+ install -Dm644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -m755 ${srcdir}/smallpdf ${pkgdir}/usr/bin
+ cp -r ${srcdir}/web/desktop/build/packages/Smallpdf-linux-x64/* ${pkgdir}/opt/smallpdf-desktop
+}
diff --git a/smallpdf b/smallpdf
new file mode 100755
index 000000000000..78f396e351f4
--- /dev/null
+++ b/smallpdf
@@ -0,0 +1,2 @@
+#!/bin/env sh
+/opt/smallpdf-desktop/Smallpdf > /dev/null
diff --git a/smallpdf-desktop.desktop b/smallpdf-desktop.desktop
new file mode 100644
index 000000000000..863d5bfe2b57
--- /dev/null
+++ b/smallpdf-desktop.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Smallpdf Desktop
+Name[de]=Smallpdf Desktop
+Name[ja]=Smallpdfデスクトップ
+Comment=Smallpdf desktop reader and converter
+Keywords=pdf;reader;converter;
+Exec=smallpdf
diff --git a/smallpdf-desktop.install b/smallpdf-desktop.install
new file mode 100644
index 000000000000..f27e8d9c5d44
--- /dev/null
+++ b/smallpdf-desktop.install
@@ -0,0 +1,8 @@
+smallpdfmessage="Run 'smallpdf' to run the reader. Please note that the\nPDF-to-Office-formats conversion tools are not available (yet)."
+
+post_install() {
+ echo -e $smallpdfmessage
+}
+post_upgrade() {
+ echo -e $smallpdfmessage
+}