summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Palenzuela2019-06-28 19:12:54 +0200
committerManuel Palenzuela2019-06-28 19:12:54 +0200
commit49b6a9313b3f5ac0ee5b613c4078f3a9ab5e3485 (patch)
tree830aa70e4f343330c41abb44e6fd240617198925
downloadaur-49b6a9313b3f5ac0ee5b613c4078f3a9ab5e3485.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a90ea2bf29e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = smart-wallpaper
+ pkgdesc = Simple script to set a different wallpaper when its daytime/nightime.
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/Baitinq/smart-wallpaper.git
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = bash
+ depends = redshift
+ depends = feh
+ optdepends = geolocate
+ provides = smart-wallpaper
+ source = git://github.com/Baitinq/smart-wallpaper.git
+ md5sums = SKIP
+ sha1sums = SKIP
+ sha256sums = SKIP
+
+pkgname = smart-wallpaper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f20cb8ef79d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Manuel Palenzuela <sadshinobi@protonmail.com>
+
+author=Baitinq
+pkgname=smart-wallpaper-git
+pkgbase=smart-wallpaper
+pkgver=0
+pkgrel=1
+pkgdesc='Simple script to set a different wallpaper when its daytime/nightime.'
+url='https://github.com/Baitinq/smart-wallpaper.git'
+arch=('any')
+license=('GPL')
+depends=('bash' 'redshift' 'feh')
+optdepends=('geolocate')
+makedepends=('git')
+provides=('smart-wallpaper')
+
+source=("git://github.com/$author/$pkgbase.git")
+
+md5sums=('SKIP')
+sha1sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgbase"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgbase"
+
+ # Install the program.
+ mkdir -p "$pkgdir/usr/share/$pkgbase"
+ install -Dm755 smart-wallpaper "${pkgdir}/usr/bin/$pkgbase"
+ chmod +x "$pkgdir/usr/bin/$pkgbase"
+ cp -a --no-preserve=ownership * "$pkgdir/usr/share/$pkgbase"
+ chmod -R 777 "$pkgdir/usr/share/$pkgbase"
+
+}