summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-04-14 19:24:06 +0200
committerMuflone2018-04-14 19:24:26 +0200
commit6783dc0bc330aebe1fe747a1747b9c451c0b0e90 (patch)
tree20ca6f1b8609b9be17fe4b9fcf308f1d5f8c398d
downloadaur-smartcvs.tar.gz
New package smartcvs 7.1.9-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--smartcvs.desktop12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fda9700de665
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Apr 14 17:20:19 UTC 2018
+pkgbase = smartcvs
+ pkgdesc = Smart, complete and powerful CVS client
+ pkgver = 7.1.9
+ pkgrel = 1
+ url = https://www.syntevo.com/smartcvs/
+ arch = any
+ license = custom
+ depends = java-runtime>=8
+ depends = gtk3
+ depends = gtk-update-icon-cache
+ source = https://www.syntevo.com/downloads/smartcvs/smartcvs-generic-7_1_9.tar.gz
+ source = smartcvs.desktop
+ sha256sums = 1928cca230a2e4c5d2e5dae846e490a2bb3c6feff6f9823ee9c9a1a0f7bfe366
+ sha256sums = c0bcdc7533f7f44e63d19096a40604a8616eb749029c37489fd4f0114cd530e9
+
+pkgname = smartcvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df989b2cf71d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=smartcvs
+pkgver=7.1.9
+pkgrel=1
+pkgdesc="Smart, complete and powerful CVS client"
+arch=("any")
+url="https://www.syntevo.com/smartcvs/"
+license=('custom')
+depends=('java-runtime>=8' 'gtk3' 'gtk-update-icon-cache')
+source=("https://www.syntevo.com/downloads/${pkgname}/${pkgname}-generic-${pkgver//\./_}.tar.gz"
+ "${pkgname}.desktop")
+sha256sums=('1928cca230a2e4c5d2e5dae846e490a2bb3c6feff6f9823ee9c9a1a0f7bfe366'
+ 'c0bcdc7533f7f44e63d19096a40604a8616eb749029c37489fd4f0114cd530e9')
+
+package() {
+ # Install desktop file
+ install -m 755 -d "${pkgdir}/usr/share/applications"
+ install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}.desktop"
+ cd "${pkgname}-${pkgver//\./_}"
+ # Install license files
+ install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" license.html
+ # Install documentation files
+ install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" changelog.txt smartcvs-reference.pdf smartcvs-tutorial.pdf
+ # Install launcher files
+ install -m 755 -d "${pkgdir}/usr/lib/${pkgname}/bin"
+ install -m 755 -t "${pkgdir}/usr/lib/${pkgname}/bin" bin/smartcvs.sh
+ install -m 755 -d "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/${pkgname}/bin/smartcvs.sh" "${pkgdir}/usr/bin/${pkgname}"
+ # Install library files
+ install -m 755 -d "${pkgdir}/usr/lib/${pkgname}/lib"
+ install -m 644 -t "${pkgdir}/usr/lib/${pkgname}/lib" lib/*
+ install -m 755 -d "${pkgdir}/usr/lib/${pkgname}/sources"
+ install -m 644 -t "${pkgdir}/usr/lib/${pkgname}/sources" sources/*
+ # Install icon files
+ for _size in 32 48 64 128
+ do
+ install -m 644 -D "bin/${pkgname}-${_size}x${_size}.png" "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps/${pkgname}.png"
+ done
+}
diff --git a/smartcvs.desktop b/smartcvs.desktop
new file mode 100644
index 000000000000..93132868ed62
--- /dev/null
+++ b/smartcvs.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=SmartCVS
+Comment=Graphical CVS client
+Exec=smartcvs
+Icon=smartcvs
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=Development;
+StartupWMClass=SmartCVS
+MimeType=application/smartcvs;application/x-smartcvs;
+