summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2022-04-17 18:32:33 +0100
committerKuoi2022-04-17 18:32:33 +0100
commitfd79de9b5f6539850c868ee51282d3b31a3c1523 (patch)
tree8e91b8844a29a1f714e3303380df62d37735b82d
downloadaur-fd79de9b5f6539850c868ee51282d3b31a3c1523.tar.gz
add smartdenovo
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7b313bfaee4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = smartdenovo
+ pkgdesc = About Ultra-fast de novo assembler using long noisy reads
+ pkgver = r80.8488de9
+ pkgrel = 1
+ url = https://github.com/ruanjue/smartdenovo
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = make
+ source = git+https://github.com/ruanjue/smartdenovo.git
+ sha256sums = SKIP
+
+pkgname = smartdenovo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9986408a7f78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Guoyi
+pkgname=smartdenovo
+pkgver=r80.8488de9
+pkgrel=1
+pkgdesc="About Ultra-fast de novo assembler using long noisy reads"
+arch=('x86_64')
+url="https://github.com/ruanjue/smartdenovo"
+license=('GPL')
+depends=()
+makedepends=('git' 'make')
+optdepends=()
+source=(git+https://github.com/ruanjue/smartdenovo.git)
+sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ #git describe --long --tags | sed 's/-/+/g' # latest+0+g844215a
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm 755 pairaln $pkgdir/usr/bin/pairaln
+ install -Dm 755 wtclp $pkgdir/usr/bin/wtclp
+ install -Dm 755 wtcns $pkgdir/usr/bin/wtcns
+ install -Dm 755 wtcyc $pkgdir/usr/bin/wtcyc
+ install -Dm 755 wtext $pkgdir/usr/bin/wtext
+ install -Dm 755 wtgbo $pkgdir/usr/bin/wtgbo
+ install -Dm 755 wtlay $pkgdir/usr/bin/wtlay
+ install -Dm 755 wtmer $pkgdir/usr/bin/wtmer
+ install -Dm 755 wtmsa $pkgdir/usr/bin/wtmsa
+ install -Dm 755 wtobt $pkgdir/usr/bin/wtobt
+ install -Dm 755 wtpre $pkgdir/usr/bin/wtpre
+ install -Dm 755 wtzmo $pkgdir/usr/bin/wtzmo
+
+}