summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-03-12 23:01:39 +0100
committerMuflone2018-03-12 23:01:39 +0100
commitaf21124959e058d433442dd831e40c2029373c65 (patch)
treee135bee09f1f19aa4fb479aafc6cdd71a8a517e5
parent98d03436ff1ff0681bbb4190d96fb45dd8b3ee2f (diff)
downloadaur-af21124959e058d433442dd831e40c2029373c65.tar.gz
Updated package smartgit 17.1.5-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD69
2 files changed, 41 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98b3bf9a2dfd..9a09c1f25542 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
# Generated by mksrcinfo v8
-# Tue Feb 6 10:33:50 UTC 2018
+# Mon Mar 12 21:59:23 UTC 2018
pkgbase = smartgit
pkgdesc = Git client with Hg and SVN support.
- pkgver = 17.1.4
- pkgrel = 2
+ pkgver = 17.1.5
+ pkgrel = 1
url = http://www.syntevo.com/smartgit
arch = any
license = custom
depends = java-runtime>=8
depends = desktop-file-utils
- depends = sh
depends = git
depends = gtk2
optdepends = mercurial: hg repositories support
replaces = smartgithg
- source = https://www.syntevo.com/downloads/smartgit/smartgit-linux-17_1_4.tar.gz
+ source = https://www.syntevo.com/downloads/smartgit/smartgit-linux-17_1_5.tar.gz
source = smartgit.desktop
- sha1sums = 8b8538769b7f49d8bc924a771b7ccf6aabaf0c11
- sha1sums = bafa47c0b43ad89aaa3b34a078771b3cd12bd1f3
+ sha256sums = 9c4dbfefa61e1ce57d65bc4b9114b80965a6e0d719c157480183083704f27eed
+ sha256sums = bb5665e9c93640b311dbe8b633da65e3c72a712a3dc9655c3274a3542a688a32
pkgname = smartgit
diff --git a/PKGBUILD b/PKGBUILD
index b259fa765c6f..c3eeb448026a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,46 @@
-#Maintainer: Alexey Stukalov <astukalov@gmail.com>
+# Maintainer: Alexey Stukalov <astukalov@gmail.com>
+# Contributor: Muflone http://www.muflone.com/contacts/english/
pkgname=smartgit
-pkgver=17.1.4
-pkgrel=2
-pkgdesc="Git client with Hg and SVN support."
-arch=("any")
+pkgver=17.1.5
+pkgrel=1
+pkgdesc='Git client with Hg and SVN support.'
+arch=('any')
url="http://www.syntevo.com/smartgit"
license=('custom')
-depends=("java-runtime>=8" "desktop-file-utils" "sh" "git" "gtk2")
-optdepends=("mercurial: hg repositories support")
-replaces=(smartgithg)
+depends=('java-runtime>=8' 'desktop-file-utils' 'git' 'gtk2')
+optdepends=('mercurial: hg repositories support')
+replaces=('smartgithg')
# package version as it appears in the name of tar.gz archive file
_pkgver=${pkgver//\./_}
# folder within tar.gz archive
_pkgfolder=${pkgname}
-source=(https://www.syntevo.com/downloads/${pkgname}/${pkgname}-linux-${_pkgver}.tar.gz
- smartgit.desktop)
-sha1sums=('8b8538769b7f49d8bc924a771b7ccf6aabaf0c11'
- 'bafa47c0b43ad89aaa3b34a078771b3cd12bd1f3')
+source=("https://www.syntevo.com/downloads/${pkgname}/${pkgname}-linux-${_pkgver}.tar.gz"
+ "${pkgname}.desktop")
+sha256sums=('9c4dbfefa61e1ce57d65bc4b9114b80965a6e0d719c157480183083704f27eed'
+ 'bb5665e9c93640b311dbe8b633da65e3c72a712a3dc9655c3274a3542a688a32')
package() {
- cd "$srcdir"
-
- #install -D -m644 "${_pkgfolder}"/licenses/* "${pkgdir}/usr/share/licenses/${pkgname}" # licenses are in /opt/smartgit/licenses
- mkdir -p "${pkgdir}"/opt
- mv "${_pkgfolder}" ${pkgdir}/opt/${pkgname} || return 1
-
- install -D -m644 smartgit.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
-
- # link icon files
- mkdir -p ${pkgdir}/usr/share/icons/hicolor/{32x32,48x48,64x64,128x128,256x256}/apps
- cd ${pkgdir}/usr/share/icons/hicolor
- ln -s /opt/${pkgname}/bin/smartgit-32.png 32x32/apps/${pkgname}.png
- ln -s /opt/${pkgname}/bin/smartgit-48.png 48x48/apps/${pkgname}.png
- ln -s /opt/${pkgname}/bin/smartgit-64.png 64x64/apps/${pkgname}.png
- ln -s /opt/${pkgname}/bin/smartgit-128.png 128x128/apps/${pkgname}.png
- ln -s /opt/${pkgname}/bin/smartgit-256.png 256x256/apps/${pkgname}.png
-
- # create link in /usr/bin
- cd ${pkgdir}
- chmod 755 opt/${pkgname}/bin/smartgit.sh
- mkdir -p usr/bin
- ln -s /opt/${pkgname}/bin/smartgit.sh usr/bin/${pkgname}
+ # Install licenses
+ install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${_pkgfolder}/licenses"/* "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${_pkgfolder}/license.html" "${pkgdir}/usr/share/licenses/${pkgname}"
+ rmdir "${_pkgfolder}/licenses"
+ # Install application files
+ install -d -m 755 "${pkgdir}/opt"
+ mv "${_pkgfolder}" "${pkgdir}/opt/${pkgname}"
+ # Install desktop file
+ install -D -m 644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ # Install icon files
+ install -d -m 755 "${pkgdir}/usr/share/icons/hicolor"
+ cd "${pkgdir}/usr/share/icons/hicolor"
+ for _size in 32 48 64 128 256
+ do
+ install -d "${_size}x${_size}/apps"
+ ln -s "/opt/${pkgname}/bin/smartgit-${_size}.png" "${_size}x${_size}/apps/${pkgname}.png"
+ done
+ # Add symlink to /usr/bin
+ chmod 755 "${pkgdir}/opt/${pkgname}/bin/smartgit.sh"
+ install -d -m 755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/bin/smartgit.sh" "${pkgdir}/usr/bin/${pkgname}"
}