summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Stukalov2015-06-08 18:37:55 +0200
committerAlexey Stukalov2015-06-08 18:37:55 +0200
commitc8e635fee4691fd927618e0f8b4a6a2b3ccb2865 (patch)
tree9fc06a7b9f9e07fef7b856cec67f6c43d509cd86
downloadaur-c8e635fee4691fd927618e0f8b4a6a2b3ccb2865.tar.gz
Initial commit (v6.5.8)
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
-rw-r--r--smartgit.desktop16
-rw-r--r--smartgit.install16
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2882fa30444b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = smartgit
+ pkgdesc = Git/Hg GUI client written in Java.
+ pkgver = 6.5.8
+ pkgrel = 1
+ url = http://www.syntevo.com/smartgit
+ install = smartgit.install
+ arch = any
+ license = custom
+ depends = java-runtime
+ depends = desktop-file-utils
+ depends = sh
+ depends = git
+ depends = gtk2
+ optdepends = mercurial: hg repositories support
+ replaces = smartgithg
+ source = https://www.syntevo.com/downloads/smartgit/smartgit-generic-6_5_8.tar.gz
+ source = smartgit.desktop
+ md5sums = 84ebfa3fbd5e039b740971c511f705ce
+ md5sums = c372fb0864ce6010c92f75910acbe8d0
+
+pkgname = smartgit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e58a20f814f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+#Maintainer: Alexey Stukalov <astukalov@gmail.com>
+pkgname=smartgit
+pkgver=6.5.8
+pkgrel=1
+pkgdesc="Git/Hg GUI client written in Java."
+arch=("any")
+url="http://www.syntevo.com/smartgit"
+license=('custom')
+depends=("java-runtime" "desktop-file-utils" "sh" "git" "gtk2")
+optdepends=("mercurial: hg repositories support")
+replaces=(smartgithg)
+
+# package version as it appears in the name of tar.gz archive file
+_pkgver=${pkgver//\./_}
+# folder within tar.gz archive
+_pkgfolder=${pkgname}
+source=(https://www.syntevo.com/downloads/${pkgname}/${pkgname}-generic-${_pkgver}.tar.gz
+ smartgit.desktop)
+install="smartgit.install"
+md5sums=('84ebfa3fbd5e039b740971c511f705ce'
+ 'c372fb0864ce6010c92f75910acbe8d0')
+
+package() {
+ cd "$srcdir"
+
+ #install -D -m644 "${_pkgfolder}"/licenses/* "${pkgdir}/usr/share/licenses/${pkgname}"
+ mkdir -p "${pkgdir}"/opt
+ mv "${_pkgfolder}" ${pkgdir}/opt/${pkgname} || return 1
+
+ install -D -m644 smartgit.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+
+ # link icon files
+ mkdir -p ${pkgdir}/usr/share/icons/hicolor/{32x32,48x48,64x64,128x128,256x256}/apps
+ cd ${pkgdir}/usr/share/icons/hicolor
+ ln -s /opt/${pkgname}/bin/smartgit-32.png 32x32/apps/${pkgname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-48.png 48x48/apps/${pkgname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-64.png 64x64/apps/${pkgname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-128.png 128x128/apps/${pkgname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-256.png 256x256/apps/${pkgname}.png
+
+ # create link in /usr/bin
+ cd ${pkgdir}
+ chmod 755 opt/${pkgname}/bin/smartgit.sh
+ mkdir -p usr/bin
+ ln -s /opt/${pkgname}/bin/smartgit.sh usr/bin/${pkgname}
+}
diff --git a/smartgit.desktop b/smartgit.desktop
new file mode 100644
index 000000000000..0c0b9d967b6d
--- /dev/null
+++ b/smartgit.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=SmartGit
+Comment=Graphical Git/Hg client
+Comment[cs]=Grafický Git/Hg klient
+Comment[de]=Ein grafischer Git/Hg Client
+Comment[zh_CN]=图形界面的 Git/Hg 客户端
+Comment[zh_HK]=圖形介面的 Git/Hg 客戶端
+Comment[zh_TW]=圖形介面的 Git/Hg 客戶端
+Exec=smartgit
+Icon=smartgit
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=Development;
+StartupWMClass=SmartGit
+MimeType=application/smartgit;application/x-smartgit;
diff --git a/smartgit.install b/smartgit.install
new file mode 100644
index 000000000000..254471508dbe
--- /dev/null
+++ b/smartgit.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "update desktop mime database..."
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_remove() {
+ echo "update desktop mime database..."
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+