summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Wirch2018-02-13 08:52:20 +0100
committerEduard Wirch2018-02-13 08:52:20 +0100
commit402392552ea093589913f34250ac3eacbf1e18be (patch)
tree04bfa0efeb1fdbd29a76aad4988ca76aaa7a53c9
parent4bc6098e52e58688f1156ed9a1c4f99aa6f52efe (diff)
downloadaur-402392552ea093589913f34250ac3eacbf1e18be.tar.gz
Update to 18.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--smartgit.desktop16
3 files changed, 17 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7b99b1a81e5..541984b72c02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = smartgit_preview
- pkgdesc = Git client with Hg and SVN support. Preview version.
- pkgver = 17.1_rc_4
+ pkgdesc = Graphical Git client. Preview version.
+ pkgver = 18.1_preview_5
pkgrel = 1
- url = https://www.syntevo.com/smartgit/preview
+ url = https://www.syntevo.com/smartgit/preview/
arch = any
license = custom
+ makedepends = tar
depends = java-environment>=8
depends = python3
- depends = hicolor-icon-theme
+ depends = bash
optdepends = mercurial: hg repositories support
optdepends = git: git repositories support
provides = smartgit
conflicts = smartgit
replaces = smartgithg
- source = https://www.syntevo.com/static/smart/download/smartgit/smartgit-linux-17.1-rc-4.tar.gz
- source = smartgit.desktop
- sha1sums = a99b817f2385e052c5c251c253a98249b7c2f259
- sha1sums = bafa47c0b43ad89aaa3b34a078771b3cd12bd1f3
+ source = https://www.syntevo.com/downloads/smartgit/smartgit-18_1-preview-5.deb
+ sha1sums = caea9fb3c2cc4db59483ae68a1a9cbae394f5107
pkgname = smartgit_preview
diff --git a/PKGBUILD b/PKGBUILD
index bacee196660e..50a2c28bb7e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,49 +3,31 @@
_appname=smartgit
pkgname=${_appname}_preview
-pkgver=17.1_rc_4
+pkgver=18.1_preview_5
pkgrel=1
-pkgdesc="Git client with Hg and SVN support. Preview version."
+pkgdesc="Graphical Git client. Preview version."
arch=("any")
-url="https://www.syntevo.com/smartgit/preview"
+url="https://www.syntevo.com/smartgit/preview/"
license=('custom')
-depends=("java-environment>=8" "python3" "hicolor-icon-theme")
+depends=("java-environment>=8" "python3" "bash")
optdepends=("mercurial: hg repositories support"
"git: git repositories support")
+makedepends=("tar")
replaces=("smartgithg")
conflicts=("smartgit")
provides=("smartgit")
# package version as it appears in the name of tar.gz archive file
_pkgver=${pkgver//_/-}
+_pkgver=${_pkgver//./_}
-source=("https://www.syntevo.com/static/smart/download/${_appname}/${_appname}-linux-${_pkgver}.tar.gz"
- "smartgit.desktop")
-sha1sums=('a99b817f2385e052c5c251c253a98249b7c2f259'
- 'bafa47c0b43ad89aaa3b34a078771b3cd12bd1f3')
+source=("https://www.syntevo.com/downloads/smartgit/${_appname}-${_pkgver}.deb")
+sha1sums=('caea9fb3c2cc4db59483ae68a1a9cbae394f5107')
package() {
cd "$srcdir"
- install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ${_appname}/licenses/*
- mkdir -p "${pkgdir}/opt"
- cp -r ${_appname} "${pkgdir}/opt/${pkgname}" || return 1
+ tar -xzf data.tar.gz -C "${pkgdir}"
- install -D -m644 smartgit.desktop "${pkgdir}/usr/share/applications/${_appname}.desktop"
-
- # link icon files
- local sizes=(32 48 64 128 256)
- local dest=
- for size in "${sizes[@]}"; do
- dest=${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps
- mkdir -p $dest
- ln -s "/opt/${pkgname}/bin/smartgit-${size}.png" "${dest}/${_appname}.png"
- done
-
- # create link in /usr/bin
- cd ${pkgdir}
- chmod 755 opt/${pkgname}/bin/smartgit.sh
- mkdir -p usr/bin
- ln -s /opt/${pkgname}/bin/smartgit.sh usr/bin/${_appname}
+ install -Dm644 "$pkgdir/usr/share/doc/$_appname/license.html" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/smartgit.desktop b/smartgit.desktop
deleted file mode 100644
index 0c0b9d967b6d..000000000000
--- a/smartgit.desktop
+++ /dev/null
@@ -1,16 +0,0 @@
-[Desktop Entry]
-Name=SmartGit
-Comment=Graphical Git/Hg client
-Comment[cs]=Grafický Git/Hg klient
-Comment[de]=Ein grafischer Git/Hg Client
-Comment[zh_CN]=图形界面的 Git/Hg 客户端
-Comment[zh_HK]=圖形介面的 Git/Hg 客戶端
-Comment[zh_TW]=圖形介面的 Git/Hg 客戶端
-Exec=smartgit
-Icon=smartgit
-Terminal=false
-X-MultipleArgs=false
-Type=Application
-Categories=Development;
-StartupWMClass=SmartGit
-MimeType=application/smartgit;application/x-smartgit;