summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeridius2016-06-26 16:44:29 +0200
committermeridius2016-06-26 17:16:09 +0200
commitb80bdc1774edd2aae3d6f7383b39027711b80734 (patch)
tree3a123686a7b24eed08b409d771f008024c16007c
downloadaur-b80bdc1774edd2aae3d6f7383b39027711b80734.tar.gz
init
7.2-preview-9
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
-rw-r--r--smartgit.desktop16
-rw-r--r--smartgit_preview.install16
5 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c60480d8be45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = smartgit_preview
+ pkgdesc = Git client with Hg and SVN support. Preview version.
+ pkgver = 7.2_preview_9
+ pkgrel = 1
+ url = https://www.syntevo.com/smartgit/preview
+ install = smartgit_preview.install
+ arch = any
+ license = custom
+ makedepends = desktop-file-utils
+ makedepends = sh
+ depends = java-environment
+ depends = python
+ depends = hicolor-icon-theme
+ optdepends = mercurial: hg repositories support
+ optdepends = git: git repositories support
+ provides = smartgit
+ conflicts = smartgit
+ replaces = smartgithg
+ source = https://www.syntevo.com/static/smart/download/smartgit/smartgit-linux-7.2-preview-9.tar.gz
+ source = smartgit.desktop
+ sha1sums = 7be106736f79ac78af5a62c06c2b5e3e34aa3d3d
+ sha1sums = bafa47c0b43ad89aaa3b34a078771b3cd12bd1f3
+
+pkgname = smartgit_preview
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a55a43d87185
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95ba228956a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+#Maintainer: Martin Lukes <martin.meridius@gmail.com>
+_appname=smartgit
+pkgname=${_appname}_preview
+pkgver=7.2_preview_9
+pkgrel=1
+pkgdesc="Git client with Hg and SVN support. Preview version."
+arch=("any")
+url="https://www.syntevo.com/smartgit/preview"
+license=('custom')
+depends=("java-environment" "python" "hicolor-icon-theme")
+makedepends=("desktop-file-utils" "sh")
+optdepends=("mercurial: hg repositories support"
+ "git: git repositories support")
+replaces=("smartgithg")
+conflicts=("smartgit")
+provides=("smartgit")
+
+# package version as it appears in the name of tar.gz archive file
+_pkgver=${pkgver//_/-}
+
+source=(https://www.syntevo.com/static/smart/download/${_appname}/${_appname}-linux-${_pkgver}.tar.gz
+ smartgit.desktop)
+install="smartgit_preview.install"
+sha1sums=('7be106736f79ac78af5a62c06c2b5e3e34aa3d3d'
+ 'bafa47c0b43ad89aaa3b34a078771b3cd12bd1f3')
+
+package() {
+ cd "$srcdir"
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${_appname}"/licenses/*
+ mkdir -p "${pkgdir}"/opt
+ mv "${_appname}" ${pkgdir}/opt/${pkgname} || return 1
+
+ install -D -m644 smartgit.desktop "${pkgdir}"/usr/share/applications/${_appname}.desktop
+
+ # link icon files
+ mkdir -p ${pkgdir}/usr/share/icons/hicolor/{32x32,48x48,64x64,128x128,256x256}/apps
+ cd ${pkgdir}/usr/share/icons/hicolor
+ ln -s /opt/${pkgname}/bin/smartgit-32.png 32x32/apps/${_appname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-48.png 48x48/apps/${_appname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-64.png 64x64/apps/${_appname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-128.png 128x128/apps/${_appname}.png
+ ln -s /opt/${pkgname}/bin/smartgit-256.png 256x256/apps/${_appname}.png
+
+ # create link in /usr/bin
+ cd ${pkgdir}
+ chmod 755 opt/${pkgname}/bin/smartgit.sh
+ mkdir -p usr/bin
+ ln -s /opt/${pkgname}/bin/smartgit.sh usr/bin/${_appname}
+}
diff --git a/smartgit.desktop b/smartgit.desktop
new file mode 100644
index 000000000000..0c0b9d967b6d
--- /dev/null
+++ b/smartgit.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=SmartGit
+Comment=Graphical Git/Hg client
+Comment[cs]=Grafický Git/Hg klient
+Comment[de]=Ein grafischer Git/Hg Client
+Comment[zh_CN]=图形界面的 Git/Hg 客户端
+Comment[zh_HK]=圖形介面的 Git/Hg 客戶端
+Comment[zh_TW]=圖形介面的 Git/Hg 客戶端
+Exec=smartgit
+Icon=smartgit
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=Development;
+StartupWMClass=SmartGit
+MimeType=application/smartgit;application/x-smartgit;
diff --git a/smartgit_preview.install b/smartgit_preview.install
new file mode 100644
index 000000000000..254471508dbe
--- /dev/null
+++ b/smartgit_preview.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "update desktop mime database..."
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_remove() {
+ echo "update desktop mime database..."
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+