summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Pohl2020-12-04 17:24:11 +0100
committerAlexander Pohl2020-12-04 17:24:11 +0100
commit00dd35311fd75159898f668734cb1b48b4624aee (patch)
treedfc4cf9449dea3ff6edfba309d4686ee79f8608d
downloadaur-00dd35311fd75159898f668734cb1b48b4624aee.tar.gz
initial package upload v2.0.5
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bbff543cb6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = smartmeter
+ pkgdesc = Read energy utility meter with IR dongle
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/ahpohl/smartmeter
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ depends = mosquitto
+ backup = etc/smartmeter.conf
+ source = smartmeter-0.2.5::git+https://github.com/ahpohl/smartmeter.git#tag=v0.2.5
+ sha256sums = SKIP
+
+pkgname = smartmeter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29fe6e8e0169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alexander Pohl <alex at ahpohl dot com>
+pkgname=smartmeter
+pkgver=0.2.5
+pkgrel=1
+epoch=
+pkgdesc="Read energy utility meter with IR dongle"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/ahpohl/smartmeter"
+license=('MIT')
+groups=()
+depends=('mosquitto')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=('etc/smartmeter.conf')
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+https://github.com/ahpohl/smartmeter.git#tag=v${pkgver}")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm644 resources/smartmeter.service "$pkgdir"/usr/lib/systemd/system/smartmeter.service
+ install -Dm644 resources/smartmeter.conf "$pkgdir"/etc/smartmeter.conf
+}