summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2015-11-26 11:59:10 +0100
committerVianney le Clément de Saint-Marcq2015-11-26 11:59:10 +0100
commite0ede042b728b9839565de23ab9d2d53af792bed (patch)
treefcba0c62a8f533ab9de139d1c93e146a727af767
downloadaur-e0ede042b728b9839565de23ab9d2d53af792bed.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
-rw-r--r--smartscope.sh2
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91ef915d01d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = smartscope-beta
+ pkgdesc = SmartScope App (Beta version)
+ pkgver = 2015.1120.23.22
+ pkgrel = 1
+ url = https://www.lab-nation.com/
+ arch = x86_64
+ arch = i686
+ license = unknown
+ makedepends = tar
+ depends = mono
+ depends = sdl_mixer
+ depends = libusb
+ provides = smartscope
+ conflicts = smartscope
+ source = smartscope-beta.deb::https://www.lab-nation.com/package/smartscope/2015/1120/23/22/linux/get
+ source = smartscope.sh
+ md5sums = a610c6c75aa34668b029c36106bde047
+ md5sums = 3d877cb9f75a3ef8887e1f81b69e8007
+
+pkgname = smartscope-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..606bff4715f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=smartscope-beta
+pkgver=2015.1120.23.22
+pkgrel=1
+pkgdesc="SmartScope App (Beta version)"
+arch=('x86_64' 'i686')
+url="https://www.lab-nation.com/"
+license=('unknown')
+depends=('mono' 'sdl_mixer' 'libusb')
+conflicts=('smartscope')
+provides=('smartscope')
+makedepends=('tar')
+
+_pkgver=$(echo ${pkgver} | sed 's@\.@/@g')
+
+source=("$pkgname.deb::https://www.lab-nation.com/package/smartscope/${_pkgver}/linux/get"
+ 'smartscope.sh')
+md5sums=('a610c6c75aa34668b029c36106bde047'
+ '3d877cb9f75a3ef8887e1f81b69e8007')
+
+package() {
+ cd "${srcdir}"
+ tar -xJvf data.tar.xz -C "${pkgdir}"
+ install -D -m755 smartscope.sh "${pkgdir}/usr/bin/smartscope"
+}
+
+# vim: set ts=2 sw=2 et:
diff --git a/smartscope.sh b/smartscope.sh
new file mode 100644
index 000000000000..fbeea1166c73
--- /dev/null
+++ b/smartscope.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec mono /opt/smartscope/SmartScope.exe "$@"