summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeinthor Rene2015-06-09 13:42:15 +0200
committerPeinthor Rene2015-06-09 13:42:15 +0200
commite33c79a6ff83e7446627a3616014f996900ef49a (patch)
treed0a5348691083f2694a587896ff174cf75caf89d
downloadaur-e33c79a6ff83e7446627a3616014f996900ef49a.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--smartsvn.desktop11
-rw-r--r--smartsvn.install20
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a8126cea91b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = smartsvn
+ pkgdesc = A Subversion(SVN) GUI client written in Java
+ pkgver = 8.6.6
+ pkgrel = 1
+ url = http://www.smartsvn.com/
+ install = smartsvn.install
+ arch = any
+ license = custom
+ depends = java-runtime
+ depends = desktop-file-utils
+ depends = sh
+ provides = smartsvn=8.6.6
+ backup = opt/smartsvn/bin/smartsvn.sh
+ source = smartsvn.desktop
+ source = http://www.smartsvn.com/downloads/smartsvn/smartsvn-linux-8_6_6.tar.gz
+ md5sums = e3dfb3bdaef28b727b491af85498f2c0
+ md5sums = 0b3dfa802949506db002d3278f0afd9b
+
+pkgname = smartsvn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..112feef01102
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#Maintainer: Rene Peinthor <peinthor@gmail.com>
+pkgname=smartsvn
+pkgver=8.6.6
+_pkgver=8_6_6
+pkgrel=1
+pkgdesc="A Subversion(SVN) GUI client written in Java"
+arch=("any")
+url="http://www.smartsvn.com/"
+license=('custom')
+depends=("java-runtime" "desktop-file-utils" "sh")
+makedepends=()
+provides=(smartsvn=$pkgver)
+source=(smartsvn.desktop http://www.smartsvn.com/downloads/${pkgname}/${pkgname}-linux-${_pkgver}.tar.gz)
+install="smartsvn.install"
+backup=('opt/smartsvn/bin/smartsvn.sh') # might contain changes to max heap size and vmoptions
+md5sums=(
+'e3dfb3bdaef28b727b491af85498f2c0'
+'0b3dfa802949506db002d3278f0afd9b'
+)
+
+
+extracted="$pkgname-$_pkgver"
+
+build() {
+ cd "$srcdir"
+ tar xzf ${pkgname}-linux-${_pkgver}.tar.gz
+}
+
+package() {
+ cd "$srcdir"
+
+ install -D -m644 "${extracted}"/license.html "${pkgdir}/usr/share/licenses/${pkgname}/license.html"
+ mkdir -p "${pkgdir}"/opt
+ mv "${extracted}" ${pkgdir}/opt/$pkgname || return 1
+
+ install -D -m644 smartsvn.desktop "${pkgdir}"/usr/share/applications/smartsvn.desktop
+}
diff --git a/smartsvn.desktop b/smartsvn.desktop
new file mode 100644
index 000000000000..108bee199a23
--- /dev/null
+++ b/smartsvn.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=SmartSVN
+Comment=A graphical Subversion client
+Comment[de]=Ein grafischer Subversion Client
+Exec=smartsvn
+Icon=/opt/smartsvn/bin/smartsvn-64.png
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=Development;
+MimeType=application/smartsvn;application/x-smartsvn;
diff --git a/smartsvn.install b/smartsvn.install
new file mode 100644
index 000000000000..ab8ee4dadc97
--- /dev/null
+++ b/smartsvn.install
@@ -0,0 +1,20 @@
+post_install() {
+ chmod 755 /opt/smartsvn/bin/smartsvn.sh
+ ln -s /opt/smartsvn/bin/smartsvn.sh /usr/bin/smartsvn
+
+ echo "update desktop mime database..."
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_remove() {
+ rm -rf /opt/smartsvn
+ unlink /usr/bin/smartsvn
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+