summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMy-Tien Nguyen2020-12-12 17:54:29 +0100
committerMy-Tien Nguyen2020-12-12 17:54:29 +0100
commit524b693dc843fcabbfdbba9fb39fcdc419008fe0 (patch)
treee130bac329c1b4485fabd8ebe9f34a70ac4dc16b
downloadaur-524b693dc843fcabbfdbba9fb39fcdc419008fe0.tar.gz
initial smartsynchronize preview package
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD46
-rw-r--r--smartsynchronize-preview.desktop12
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f3395d97675
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = smartsynchronize-preview
+ pkgdesc = Comparing Directories the Smart Way
+ pkgver = 4.2_preview_1
+ pkgrel = 1
+ url = https://www.syntevo.com/smartsynchronize/
+ arch = any
+ license = custom
+ depends = java-runtime>=11
+ depends = gtk3
+ depends = gtk-update-icon-cache
+ source = https://www.syntevo.com/downloads/smartsynchronize/smartsynchronize-linux-4_2-preview-1.tar.gz
+ source = smartsynchronize-preview.desktop
+ sha1sums = fc6358c249ddc349b0114da377903c596e5cd23d
+ sha1sums = 6bf796d102c280d71bd3d443b25b1997e82104dd
+
+pkgname = smartsynchronize-preview
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6fed5b7e056a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*tar.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8843e903c2fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Alexey Stukalov <astukalov@gmail.com>
+
+appname=smartsynchronize
+pkgname=${appname}-preview
+pkgver=4.2_preview_1
+pkgrel=1
+pkgdesc="Comparing Directories the Smart Way"
+arch=("any")
+url="https://www.syntevo.com/smartsynchronize/"
+license=('custom')
+depends=('java-runtime>=11' 'gtk3' 'gtk-update-icon-cache')
+
+pkgver_tar=${pkgver//_/-}
+pkgver_tar=${pkgver_tar//./_}
+source=("https://www.syntevo.com/downloads/${appname}/${appname}-linux-${pkgver_tar}.tar.gz"
+ "${pkgname}.desktop")
+
+sha1sums=("fc6358c249ddc349b0114da377903c596e5cd23d"
+ "6bf796d102c280d71bd3d443b25b1997e82104dd")
+
+package() {
+ # Install desktop file
+ install -m 755 -d "${pkgdir}/usr/share/applications"
+ install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}.desktop"
+ cd "${appname}"
+ # Install license files
+ install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" license.html licenses/*
+ # Install documentation files
+ install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" readme-linux.txt changelog.txt smartsynchronize.pdf
+ # Install launcher files
+ install -m 755 -d "${pkgdir}/usr/lib/${pkgname}/bin"
+ install -m 755 -t "${pkgdir}/usr/lib/${pkgname}/bin" bin/smartsynchronize.sh
+ install -m 755 -d "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/${pkgname}/bin/smartsynchronize.sh" "${pkgdir}/usr/bin/${pkgname}"
+ # Install library files
+ install -m 755 -d "${pkgdir}/usr/lib/${pkgname}/lib"
+ install -m 644 -t "${pkgdir}/usr/lib/${pkgname}/lib" lib/*
+ # Install icon files
+ for _size in 32 48 64 128 256
+ do
+ install -m 644 -D "bin/${appname}-${_size}.png" "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps/${pkgname}.png"
+ done
+}
diff --git a/smartsynchronize-preview.desktop b/smartsynchronize-preview.desktop
new file mode 100644
index 000000000000..17845c0726a9
--- /dev/null
+++ b/smartsynchronize-preview.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=SmartSynchronize preview
+Keywords=compare;merge;synchronize
+GenericName=File and Directory Compare
+Type=Application
+Categories=Development
+Terminal=false
+StartupNotify=true
+Exec=smartsynchronize-preview %f
+Icon=smartsynchronize