summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Frączek2017-12-23 00:00:01 +0100
committerRafał Frączek2017-12-23 00:00:01 +0100
commit1d875ad82a09232ed153b9a2d7b644125acdc744 (patch)
treef5cd92c1612573bfea990b273a1a01de0205e0e5
downloadaur-1d875ad82a09232ed153b9a2d7b644125acdc744.tar.gz
the first release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
-rw-r--r--smarttrafficmeter.install28
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..845ac18a67e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = smarttrafficmeter
+ pkgdesc = Software for measuring network usage
+ pkgver = 2.1.1227.6875
+ pkgrel = 1
+ install = smarttrafficmeter.install
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = git
+ makedepends = boost
+ makedepends = curl
+ makedepends = binutils
+ depends = boost-libs
+ depends = curl
+ provides = smarttrafficmeter
+
+pkgname = smarttrafficmeter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd2f109754e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Rafał Frączek <rafalfr@protonmail.ch>
+pkgname=smarttrafficmeter
+pkgver=2.1.1227.6875
+pkgrel=1
+pkgdesc="Software for measuring network usage"
+arch=('x86_64')
+url=""
+license=('GPL3')
+depends=('boost-libs' 'curl')
+makedepends=('gcc' 'git' 'boost' 'curl' 'binutils')
+checkdepends=()
+optdepends=()
+provides=('smarttrafficmeter')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install='smarttrafficmeter.install'
+changelog=
+source=()
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+build() {
+ git clone --depth 1 "https://rafalfr@bitbucket.org/rafalfr/smarttrafficmeter.git"
+ cd ${srcdir}/smarttrafficmeter/
+ make -f SmartTrafficMeter.cbp.mak linux_release
+}
+
+package() {
+ install -D -m755 ${srcdir}/smarttrafficmeter/bin/Release/smarttrafficmeter ${pkgdir}/usr/bin/smarttrafficmeter
+ install -D -m755 ${srcdir}/smarttrafficmeter/install/smarttrafficmeter.service ${pkgdir}/usr/lib/systemd/system/smarttrafficmeter.service
+ }
diff --git a/smarttrafficmeter.install b/smarttrafficmeter.install
new file mode 100644
index 000000000000..b7bf6154a221
--- /dev/null
+++ b/smarttrafficmeter.install
@@ -0,0 +1,28 @@
+post_install() {
+ systemctl enable smarttrafficmeter
+ systemctl start smarttrafficmeter
+ echo "#####################################################################"
+ echo "# #"
+ echo "# Smart Traffic Meter should now be running as a service (daemon) #"
+ echo "# Open your web browser and navigate to 127.0.0.1:7676 #"
+ echo "# If the page does not open #"
+ echo "# you may need to execute the following comands in the command line #"
+ echo "# sudo systemctl enable smarttrafficmeter #"
+ echo "# sudo systemctl start smarttrafficmeter #"
+ echo "# and restart your computer #"
+ echo "# #"
+ echo "#####################################################################"
+}
+
+pre_upgrade() {
+ systemctl stop smarttrafficmeter
+}
+
+post_upgrade() {
+ systemctl start smarttrafficmeter
+}
+
+pre_remove() {
+ systemctl stop smarttrafficmeter
+ systemctl disable smarttrafficmeter
+}