summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Torres2015-06-09 17:11:00 +0200
committerJavier Torres2015-06-09 17:11:00 +0200
commit47773c48720c55b6f52e9c4ab8561022c43334d7 (patch)
treeaa94e960ec0e5e594562bdc2935ce4e4f56f55b8
downloadaur-47773c48720c55b6f52e9c4ab8561022c43334d7.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99e594513fe7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = smarty3
+ pkgdesc = Smarty is a PHP template engine
+ pkgver = 3.1.21
+ pkgrel = 1
+ url = http://www.smarty.net
+ arch = any
+ license = LGPL
+ depends = php>=5.2
+ source = http://www.smarty.net/files/Smarty-3.1.21.tar.gz
+ sha256sums = e872f98a194a31b9dea710fceb308431c0e2b846e46ce845b547f54e5789c465
+
+pkgname = smarty3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..710ea65bf729
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Javier Torres <javitonino [at] gmail [dot] com>
+# Contributor: Daniel Ehlers <danielehlers@mindeye.net>
+
+pkgname=smarty3
+pkgver=3.1.21
+pkgrel=1
+pkgdesc='Smarty is a PHP template engine'
+url='http://www.smarty.net'
+license='LGPL'
+depends=('php>=5.2')
+arch=('any')
+source=("http://www.smarty.net/files/Smarty-${pkgver}.tar.gz")
+sha256sums=('e872f98a194a31b9dea710fceb308431c0e2b846e46ce845b547f54e5789c465')
+
+package() {
+ install -d "${pkgdir}/usr/share/php"
+ cp -dpr --no-preserve=ownership "${srcdir}/Smarty-${pkgver}/libs" "${pkgdir}/usr/share/php/smarty3"
+}