summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlawekNowy2023-03-01 17:47:05 +0100
committerSlawekNowy2023-03-01 17:47:05 +0100
commit956911482ffab5dc11e7075115cde8077a59fde2 (patch)
treeb5d8b35801429edd8e71c7ff42e1b57fe748723c
parentafa4dd3b1f942a33e63f1dd0ed28642c33c81fe2 (diff)
downloadaur-956911482ffab5dc11e7075115cde8077a59fde2.tar.gz
Version bump, upstream change, and autoconf fixes
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
-rw-r--r--fix_autoreconf_warnings.patch89
-rw-r--r--smbldap-config.pl.patch18
4 files changed, 105 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ee14367dd92..2467911504de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = smbldap-tools
pkgdesc = A set of perl scripts designed to manage user and group accounts stored in an LDAP directory.
- pkgver = 0.9.10
+ pkgver = 0.9.11
pkgrel = 1
url = https://gna.org/projects/smbldap-tools/
arch = any
license = GPL
+ makedepends = automake
+ makedepends = autoconf
depends = samba
depends = openldap
depends = perl-digest-sha1
@@ -14,10 +16,9 @@ pkgbase = smbldap-tools
depends = perl-io-socket-ssl
backup = etc/smbldap-tools/smbldap.conf
backup = etc/smbldap-tools/smbldap_bind.conf
- source = http://download.gna.org/smbldap-tools/sources/0.9.10/smbldap-tools-0.9.10.tar.gz
- source = smbldap-config.pl.patch
- md5sums = f52a626637c468d66a4e71f30c174873
- md5sums = 36aed03f5fa270bd8ac5849feb200d46
+ source = https://github.com/fumiyas/smbldap-tools/archive/v0.9.11.tar.gz
+ source = fix_autoreconf_warnings.patch
+ sha256sums = f8d43f7bb5b6cbea29e519b8d9cedd287e9c15978e9deb1fa1892618d2c8639c
+ sha256sums = 5c7b5680923fba460707c96d74998ed33fbeb4d99913d855cb2e0f5af2b9b758
pkgname = smbldap-tools
-
diff --git a/PKGBUILD b/PKGBUILD
index 556ba2454571..cec58c8742f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
+# Maintainer: SÅ‚awomir Spiewak <slawekwaga [at] gmail [dot] com>
# Maintainer: Emile Pesik <ristridin [at] gmail [dot] com>
# Contributor: Martin Imobersteg <imm [at] gmx [dot] ch>
pkgname=smbldap-tools
-pkgver=0.9.10
+pkgver=0.9.11
pkgrel=1
pkgdesc="A set of perl scripts designed to manage user and group accounts stored in an LDAP directory."
arch=(any)
url="https://gna.org/projects/smbldap-tools/"
license=("GPL")
depends=('samba' 'openldap' 'perl-digest-sha1' 'perl-unicode-maputf8' 'perl-crypt-smbhash' 'perl-ldap' 'perl-io-socket-ssl')
-source=("http://download.gna.org/smbldap-tools/sources/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'smbldap-config.pl.patch')
+makedepends=('automake' 'autoconf')
+source=("https://github.com/fumiyas/smbldap-tools/archive/v${pkgver}.tar.gz"
+"fix_autoreconf_warnings.patch")
backup=(etc/smbldap-tools/smbldap.conf etc/smbldap-tools/smbldap_bind.conf)
-md5sums=('f52a626637c468d66a4e71f30c174873'
- '36aed03f5fa270bd8ac5849feb200d46')
+sha256sums=('f8d43f7bb5b6cbea29e519b8d9cedd287e9c15978e9deb1fa1892618d2c8639c'
+'5c7b5680923fba460707c96d74998ed33fbeb4d99913d855cb2e0f5af2b9b758')
prepare() {
cd $srcdir/${pkgname}-${pkgver}
- patch -p1 -i $srcdir/smbldap-config.pl.patch
+ patch -p1 -i $srcdir/fix_autoreconf_warnings.patch
}
build() {
cd $srcdir/${pkgname}-${pkgver}
+ build/autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin
make
}
diff --git a/fix_autoreconf_warnings.patch b/fix_autoreconf_warnings.patch
new file mode 100644
index 000000000000..76adaff04119
--- /dev/null
+++ b/fix_autoreconf_warnings.patch
@@ -0,0 +1,89 @@
+diff --git a/build/autogen.sh b/build/autogen.sh
+index e35d2ee..cf9b75a 100755
+--- a/build/autogen.sh
++++ b/build/autogen.sh
+@@ -5,7 +5,7 @@ set -e
+
+ rm -rf autom4te*.cache
+
+-grep AC_CONFIG_HEADER configure.in >/dev/null && autoheader
++grep AC_CONFIG_HEADER configure.ac >/dev/null && autoheader
+ autoconf
+
+ rm -rf autom4te*.cache
+diff --git a/configure.in b/configure.ac
+similarity index 85%
+rename from configure.in
+rename to configure.ac
+index d28211e..3af0f1e 100644
+--- a/configure.in
++++ b/configure.ac
+@@ -1,9 +1,9 @@
+ ## smbldap-tools configure.in
+ ## ======================================================================
+
+-AC_PREREQ(2.50)
++AC_PREREQ([2.71])
+
+-AC_INIT(smbldap-tools, 0.9.11)
++AC_INIT([smbldap-tools],[0.9.11])
+
+ AC_PREFIX_DEFAULT(/usr/local)
+
+@@ -30,8 +30,7 @@ AC_SUBST(package_subdir)
+
+ AC_ARG_WITH(
+ subdir,
+- [AC_HELP_STRING(--with-subdir=DIR,
+- [change default subdirectory used for installs])],
++ [AS_HELP_STRING([--with-subdir=DIR],[change default subdirectory used for installs])],
+ [package_subdir="$withval"],
+ )
+
+@@ -52,7 +51,7 @@ AC_SUBST(PERL_COMMAND)
+
+ AC_ARG_WITH(
+ perl,
+- [AC_HELP_STRING(--with-perl=PATH, [Use specific perl command])],
++ [AS_HELP_STRING([--with-perl=PATH],[Use specific perl command])],
+ [PERL_COMMAND="$withval"],
+ )
+
+@@ -95,7 +94,7 @@ AC_SUBST(PERL_LIBDIR)
+
+ AC_ARG_WITH(
+ perl-libdir,
+- [AC_HELP_STRING(--with-perl-libdir=PATH,[*.pm install directory])],
++ [AS_HELP_STRING([--with-perl-libdir=PATH],[*.pm install directory])],
+ [PERL_LIBDIR="$withval"],
+ )
+
+@@ -118,7 +117,7 @@ AC_SUBST(POD2MAN_COMMAND)
+
+ AC_ARG_WITH(
+ pod2man,
+- [AC_HELP_STRING(--with-pod2man=PATH, [Use specific pod2man command])],
++ [AS_HELP_STRING([--with-pod2man=PATH],[Use specific pod2man command])],
+ [POD2MAN_COMMAND="$withval"],
+ )
+
+@@ -139,8 +138,7 @@ AC_SUBST(SAMBA_SYSCONFDIR)
+
+ AC_ARG_WITH(
+ samba-sysconfdir,
+- [AC_HELP_STRING(--with-samba-sysconfdir=DIR,
+- [Path for Samba sysconf directory])],
++ [AS_HELP_STRING([--with-samba-sysconfdir=DIR],[Path for Samba sysconf directory])],
+ [SAMBA_SYSCONFDIR="$withval"],
+ )
+
+@@ -152,8 +150,7 @@ AC_SUBST(SAMBA_BINDIR)
+
+ AC_ARG_WITH(
+ samba_bindir,
+- [AC_HELP_STRING([--with-samba-bindir=DIR],
+- [Path for Samba bin directory])],
++ [AS_HELP_STRING([--with-samba-bindir=DIR],[Path for Samba bin directory])],
+ [SAMBA_BINDIR="$withval"],
+ )
+
diff --git a/smbldap-config.pl.patch b/smbldap-config.pl.patch
deleted file mode 100644
index 6329bc40def1..000000000000
--- a/smbldap-config.pl.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -aur smbldap-tools-0.9.10/smbldap-config.pl smbldap-tools-0.9.10-modified/smbldap-config.pl
---- smbldap-tools-0.9.10/smbldap-config.pl 2012-03-05 08:59:44.000000000 +0000
-+++ smbldap-tools-0.9.10-modified/smbldap-config.pl 2013-05-30 16:16:01.739410399 +0100
-@@ -557,3 +557,14 @@
- $mode=0600;
- chmod $mode,"$smbldap_bind_conf","$smbldap_bind_conf.old";
-
-+_END_
-+
-+=head1 NAME
-+
-+smbldap-config - Configure the smbldap-tools
-+
-+=head1 SYNOPSIS
-+
-+smbldap-config
-+
-+=head1 DESCRIPTION