summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2013-03-22 18:32:20 -0600
committerBrian Bidulock2015-06-10 16:08:31 -0600
commit476aa497583698d552eb6a6f81cc1400b869e957 (patch)
tree357b37c7f6bcbd1334780757450120d99a122f44
parent65819e24b57ee52e0d2ac68317ee27eb8b007243 (diff)
downloadaur-476aa497583698d552eb6a6f81cc1400b869e957.tar.gz
version 1.99.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--smcroute.conf.example11
-rw-r--r--smcroute.service2
4 files changed, 20 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 530c41c159c9..245facda85b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = smcroute
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 2.0.0
+ pkgver = 1.99.0
pkgrel = 1
- url = https://troglobit.com/smcroute.html
+ url = https://github.com/troglobit/smcroute
arch = i686
arch = x86_64
license = GPL2
- depends = glibc
+ depends = bash
provides = smcroute
provides = mcsender
backup = etc/smcroute.conf
- source = ftp://troglobit.com/smcroute/smcroute-2.0.0.tar.xz
+ source = https://github.com/downloads/troglobit/smcroute/smcroute-1.99.0.tar.bz2
source = smcroute.conf.example
source = smcroute.service
- md5sums = cbf478e52ab9ae411adca41b9d22f68a
- md5sums = 98bdb5bbd222686761e318ee04825b7a
- md5sums = 7b28500642045b2482f5ac873da0f86b
+ md5sums = 8f3e3abd6891141c7d5e555c6315ddfd
+ md5sums = 59fdb2baf1184d0cb5c59b576b1b5e1c
+ md5sums = 5a50ffb78f0a6087e3ac944df034eb90
pkgname = smcroute
diff --git a/PKGBUILD b/PKGBUILD
index 5f8b261e8ac9..2763ce3a83af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Brian Bidulock <bidulock@openss7.org>
-# Contributor: Julien Sopena (jsopena.archlinux@free.fr)
+# Maintainer: Julien Sopena (jsopena.archlinux@free.fr)
pkgname="smcroute"
-pkgver="2.0.0"
+pkgver="1.99.0"
pkgrel=1
pkgdesc="A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing."
arch=('i686' 'x86_64')
-url="https://troglobit.com/smcroute.html"
+url="https://github.com/troglobit/smcroute"
license=('GPL2')
+depends=(bash)
provides=('smcroute' 'mcsender')
backup=('etc/smcroute.conf')
-depends=('glibc')
-source=("ftp://troglobit.com/smcroute/$pkgname-$pkgver.tar.xz"
+source=("https://github.com/downloads/troglobit/smcroute/$pkgname-$pkgver.tar.bz2"
'smcroute.conf.example'
'smcroute.service')
-md5sums=('cbf478e52ab9ae411adca41b9d22f68a'
- '98bdb5bbd222686761e318ee04825b7a'
- '7b28500642045b2482f5ac873da0f86b')
+noextract=()
+md5sums=('8f3e3abd6891141c7d5e555c6315ddfd'
+ '59fdb2baf1184d0cb5c59b576b1b5e1c'
+ '5a50ffb78f0a6087e3ac944df034eb90')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --sbindir=/usr/bin
+ ./configure --prefix=/usr
make
}
@@ -29,8 +29,6 @@ package() {
install -Dm644 "${srcdir}/smcroute.conf.example" "${pkgdir}/etc/smcroute.conf"
install -Dm644 "${srcdir}/smcroute.service" "${pkgdir}/usr/lib/systemd/system/smcroute.service"
- # nothing useful here
- rm -fr "${pkgdir}/usr/share/doc"
}
# vim:set ts=2 sw=2 et:
diff --git a/smcroute.conf.example b/smcroute.conf.example
index d8b8d73cd54c..b587fc706c39 100644
--- a/smcroute.conf.example
+++ b/smcroute.conf.example
@@ -11,21 +11,14 @@
#
# Syntax:
# mgroup from IFNAME group MCGROUP
-# mroute from IFNAME [source ADDRESS] group MCGROUP to IFNAME [IFNAME ...]
+# mroute from IFNAME source ADDRESS group MCGROUP to IFNAME [IFNAME ...]
#
# The following example instructs the kernel to join the multicast
# group 225.1.2.3 on interface eth0. Followed by setting up an
# mroute of the same multicast stream, but from the explicit sender
# 192.168.1.42 on the eth0 network and forward to eth1 and eth2.
#
+
# mgroup from eth0 group 225.1.2.3
# mroute from eth0 group 225.1.2.3 source 192.168.1.42 to eth1 eth2
-# Here we allow routing of multicast to group 225.3.2.1 from ANY
-# source coming in from interface eth0 and forward to eth1 and eth2.
-# NOTE: Routing from ANY source is currently only available for IPv4
-# multicast.
-#
-# mgroup from eth0 group 225.3.2.1
-# mroute from eth0 group 225.3.2.1 to eth1 eth2
-
diff --git a/smcroute.service b/smcroute.service
index 6d82b4e0a48a..345068a46610 100644
--- a/smcroute.service
+++ b/smcroute.service
@@ -7,7 +7,7 @@ Conflicts=pimd.service mrouted.service
[Service]
Type=forking
PIDFile=/var/run/smcroute.pid
-ExecStart=/usr/bin/smcroute -d
+ExecStart=/usr/sbin/smcroute -d
ExecReload=/bin/kill -HUP $MAINPID
Restart=on-abort