summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-09-29 18:30:49 -0600
committerBrian Bidulock2015-06-10 16:18:19 -0600
commit4c228f729efd01cb0ca8c388d4965ace5a37e316 (patch)
tree50c1400119b19a5cdd443442ca5208bae73871d9
parent3f025e8abb8c3ed539244f2dea0a44bf7fcb6520 (diff)
downloadaur-4c228f729efd01cb0ca8c388d4965ace5a37e316.tar.gz
version 1.99.2.r91.gff0a2c0-1
-rw-r--r--.AURINFO8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
3 files changed, 14 insertions, 24 deletions
diff --git a/.AURINFO b/.AURINFO
index 55d9151a7ad1..a3fb5f81c66a 100644
--- a/.AURINFO
+++ b/.AURINFO
@@ -1,22 +1,20 @@
pkgbase = smcroute-git
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 1.99.2.r65.ga8326b7
+ pkgver = 1.99.2.r91.gff0a2c0
pkgrel = 1
url = https://github.com/troglobit/smcroute
arch = i686
arch = x86_64
license = GPL2
- depends = bash
+ depends = glibc
provides = smcroute
provides = mcsender
conflicts = smcroute
conflicts = mcsender
source = smcroute-git::git+https://github.com/troglobit/smcroute.git
source = smcroute.conf.example
- source = smcrouted.conf.d
- source = smcrouted.rc.d
+ source = smcroute.service
backup = etc/smcroute.conf
- backup = etc/conf.d/smcrouted
pkgname = smcroute-git
diff --git a/.SRCINFO b/.SRCINFO
index 46a5a09e0811..6f8f054d5341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
pkgbase = smcroute-git
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 1.99.2.r65.ga8326b7
+ pkgver = 1.99.2.r91.gff0a2c0
pkgrel = 1
url = https://github.com/troglobit/smcroute
arch = i686
arch = x86_64
license = GPL2
- depends = bash
+ depends = glibc
provides = smcroute
provides = mcsender
conflicts = smcroute
conflicts = mcsender
backup = etc/smcroute.conf
- backup = etc/conf.d/smcrouted
source = smcroute-git::git+https://github.com/troglobit/smcroute.git
source = smcroute.conf.example
- source = smcrouted.conf.d
- source = smcrouted.rc.d
+ source = smcroute.service
md5sums = SKIP
md5sums = 59fdb2baf1184d0cb5c59b576b1b5e1c
- md5sums = aed88a7472e9daef0b783d017735c8f4
- md5sums = b925ad844fe57f017ed5f840b86e701d
+ md5sums = 7b28500642045b2482f5ac873da0f86b
pkgname = smcroute-git
diff --git a/PKGBUILD b/PKGBUILD
index 073c96656539..6c737dc9a1dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname="smcroute-git"
-pkgver=1.99.2.r65.ga8326b7
+pkgver=1.99.2.r91.gff0a2c0
pkgrel=1
pkgdesc="A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing."
arch=('i686' 'x86_64')
url="https://github.com/troglobit/smcroute"
license=('GPL2')
-groups=()
-depends=('bash')
+depends=('glibc')
provides=('smcroute' 'mcsender')
conflicts=('smcroute' 'mcsender')
-backup=('etc/smcroute.conf' 'etc/conf.d/smcrouted')
+backup=('etc/smcroute.conf')
source=("$pkgname::git+https://github.com/troglobit/smcroute.git"
'smcroute.conf.example'
- 'smcrouted.conf.d'
- 'smcrouted.rc.d')
+ 'smcroute.service')
noextract=()
md5sums=('SKIP'
'59fdb2baf1184d0cb5c59b576b1b5e1c'
- 'aed88a7472e9daef0b783d017735c8f4'
- 'b925ad844fe57f017ed5f840b86e701d')
+ '7b28500642045b2482f5ac873da0f86b')
pkgver() {
cd $pkgname
@@ -29,7 +26,7 @@ pkgver() {
build() {
cd $pkgname
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --sbindir=/usr/bin
make
}
@@ -37,10 +34,8 @@ package() {
cd $pkgname
make DESTDIR="$pkgdir/" install
- # install rc script and its configuration file
install -Dm644 "${srcdir}/smcroute.conf.example" "${pkgdir}/etc/smcroute.conf"
- install -Dm644 "${srcdir}/smcrouted.conf.d" "${pkgdir}/etc/conf.d/smcrouted"
- install -Dm755 "${srcdir}/smcrouted.rc.d" "${pkgdir}/etc/rc.d/smcrouted"
+ install -Dm644 "${srcdir}/smcroute.service" "${pkgdir}/usr/lib/systemd/system/smcroute.service"
}
# vim:set ts=2 sw=2 et: