summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Ryzhikov2021-09-13 11:38:48 +0300
committerPlaton Ryzhikov2021-09-13 11:39:45 +0300
commitd46cfb42a5936550467fd2cc5c93e95bb0260755 (patch)
tree45a1d3f8c24ad85c01b23bf6809a8bf672d3c624
parente88d1cddec9d9d18611fad277ef55aa6661c5bdc (diff)
downloadaur-d46cfb42a5936550467fd2cc5c93e95bb0260755.tar.gz
update to 0.2.3-10
-rw-r--r--.SRCINFO6
-rw-r--r--00-modprobe2
-rw-r--r--99-remove_links8
-rw-r--r--PKGBUILD9
-rw-r--r--smdev.install12
5 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb6e7a01520e..c7cfa8ce093d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = smdev-phkr
pkgdesc = Suckless mdev
pkgver = 0.2.3
- pkgrel = 9
+ pkgrel = 10
url = http://git.suckless.org/smdev/
install = smdev.install
arch = i686
@@ -27,8 +27,8 @@ pkgbase = smdev-phkr
sha1sums = f0e3bfc2956d0c8885e08732cff8d0f9b6cf7103
sha1sums = 1f6b9327866981ffab4a275a64ee5c5249038968
sha1sums = d741887a118ed921528189754d886159782ca6fe
- sha1sums = 04745465d144a8cf4e367c5a42ab8a0bc39622b3
- sha1sums = 6a5369d9e3efc4317c907cc6140e509e82a559a5
+ sha1sums = 396e84460ba95dcf3aeaaf9f2bc711be92a2c395
+ sha1sums = 2fa17e2c0ab472fb1ec7a1b04630393df67cf07a
sha1sums = 7fe74315c9a3592c2eb66cea8cd652da04461786
sha1sums = ea04c776d0f6b749bfd1fc421d51c5ecd07379b5
diff --git a/00-modprobe b/00-modprobe
index 7a23e40586e4..dd483f9d840c 100644
--- a/00-modprobe
+++ b/00-modprobe
@@ -1 +1 @@
-[ "$MODALIAS" ] && modprobe "$MODALIAS"
+[ "$MODALIAS" ] && modprobe "$MODALIAS" 2> /dev/null
diff --git a/99-remove_links b/99-remove_links
index b78ddfd00ae2..cbabd1cdb23d 100644
--- a/99-remove_links
+++ b/99-remove_links
@@ -1,7 +1 @@
-if [[ $DEVNAME ]]; then
- for lnk in $(find /dev -type l -exec ls -al {} \; | grep /dev/$DEVNAME); do
- if [[ $(echo $lnk | awk '{print $11}') == /dev/$DEVNAME ]]; then
- rm -f $(echo $lnk | awk '{print $9}')
- fi
- done
-fi
+[ "$DEVNAME" ] && find /dev -type l -exec sh -c 'for i in "$@"; do [ "$0" = "$(realpath -- "$i")" ] && rm -f -- "$i"; done' "/dev/$DEVNAME" {} +
diff --git a/PKGBUILD b/PKGBUILD
index 6b3391104c73..a97299c55be6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
pkgbase=smdev-phkr
pkgname=smdev
pkgver=0.2.3
-pkgrel=9
+pkgrel=10
_rev=8d07540
pkgdesc='Suckless mdev'
arch=('i686' 'x86_64' 'aarch64')
url="http://git.suckless.org/smdev/"
makedepends=( 'git' )
provides=('mdev')
-#depends=( 'mksh' ) # mksh allows to procced scripts faster with almost bash compatible syntax
license=( 'MIT/X' )
options=( 'strip' )
install='smdev.install'
@@ -33,8 +32,8 @@ sha1sums=('SKIP'
'f0e3bfc2956d0c8885e08732cff8d0f9b6cf7103'
'1f6b9327866981ffab4a275a64ee5c5249038968'
'd741887a118ed921528189754d886159782ca6fe'
- '04745465d144a8cf4e367c5a42ab8a0bc39622b3'
- '6a5369d9e3efc4317c907cc6140e509e82a559a5'
+ '396e84460ba95dcf3aeaaf9f2bc711be92a2c395'
+ '2fa17e2c0ab472fb1ec7a1b04630393df67cf07a'
'7fe74315c9a3592c2eb66cea8cd652da04461786'
'ea04c776d0f6b749bfd1fc421d51c5ecd07379b5')
@@ -58,7 +57,7 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
cd "${srcdir}"
install -m744 -D processdev ${pkgdir}/etc/smdev/processdev
- install -m644 -D 00-modprobe $pkgdir/etc/smdev/add/00-modprobe
+ install -m644 -D 00-modprobe $pkgdir/etc/smdev/00-modprobe
install -m644 -D 99-remove_links $pkgdir/etc/smdev/remove/99-remove_links
install -m644 -D initcpio.hook $pkgdir/usr/lib/initcpio/hooks/smdev
install -m644 -D initcpio.install $pkgdir/usr/lib/initcpio/install/smdev
diff --git a/smdev.install b/smdev.install
index c2cc6d104ab1..e8fc4afdb838 100644
--- a/smdev.install
+++ b/smdev.install
@@ -1,8 +1,14 @@
+modprobe_info() {
+ echo "00-modprobe is placed in /etc/smdev. If you want smdev to handle MODALIAS (e.g. it is not handled on higher level), add this script to /etc/smdev/add"
+}
+
post_install() {
id cdrom &>/dev/null || {
groupadd cdrom
}
- id cdrom &>/dev/null || {
- groupadd usb
- }
+ modprobe_info
+}
+
+post_upgrade() {
+ modprobe_info
}