summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2024-04-03 13:09:41 -0300
committerFilipe Nascimento2024-04-03 13:15:40 -0300
commit7dcda8898dcda143bdede6e3ff99bda95ba4ee43 (patch)
tree964049c37736f64dcc41e50b15f509b22c71986c
parenta7f31fe23e1e04883746401ee1d3636319ff5d9f (diff)
downloadaur-7dcda8898dcda143bdede6e3ff99bda95ba4ee43.tar.gz
upgpkg: smenu 1.4.0-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0b79f15c386..de0d614cb323 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = smenu
pkgdesc = A powerful and versatile selection tool for interactive or scripting use
- pkgver = 1.3.0
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/p-gen/smenu
arch = x86_64
- license = GPL
+ license = MPL-2.0
depends = ncurses
- source = smenu-1.3.0.tar.gz::https://github.com/p-gen/smenu/archive/v1.3.0.tar.gz
- sha256sums = f69480f98e0bb42f3465a303a109c968ad29e6757a6fb94595ded61b4896ad3e
+ source = smenu-1.4.0.tar.gz::https://github.com/p-gen/smenu/archive/v1.4.0.tar.gz
+ sha256sums = 76b5f2ba181ac4d377fde30181fc6f2ecc7cdef82cf78796c18e59b7a033b9c9
pkgname = smenu
diff --git a/PKGBUILD b/PKGBUILD
index a6cca0553a49..a58a4f25bd7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Morten Linderud <foxboron@archlinux.org>
pkgname=smenu
-pkgver=1.3.0
+pkgver=1.4.0
pkgrel=1
pkgdesc="A powerful and versatile selection tool for interactive or scripting use"
arch=('x86_64')
url="https://github.com/p-gen/smenu"
-license=('GPL')
+license=('MPL-2.0')
depends=('ncurses')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/p-gen/smenu/archive/v${pkgver}.tar.gz")
-sha256sums=('f69480f98e0bb42f3465a303a109c968ad29e6757a6fb94595ded61b4896ad3e')
+sha256sums=('76b5f2ba181ac4d377fde30181fc6f2ecc7cdef82cf78796c18e59b7a033b9c9')
build() {
cd "${pkgname}-${pkgver}"
@@ -21,4 +21,6 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" PREFIX=/usr install
+ install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname"
+ find examples/ -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/doc/$pkgname/{}" \;
}