summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2020-10-16 14:39:25 -0300
committerFilipe Nascimento2020-10-16 14:39:25 -0300
commit8575d4c182d5cf560573819f417851bc177d8c63 (patch)
tree2c9746d8a592aea273f236704b8cfac750ea4446
parent4ad0a23b5fed480048b93f5d2bc7a94d06afed51 (diff)
downloadaur-8575d4c182d5cf560573819f417851bc177d8c63.tar.gz
upgpkg: smenu 0.9.16-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 110568dc59e4..b060f05ab670 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Fri Jan 26 21:01:15 UTC 2018
pkgbase = smenu
- pkgdesc = Terminal utility that allows you to use words coming from the standard input to create a nice selection window just below the cursor. Once done, your selection will be sent to standard output.
- pkgver = 0.9.11
+ pkgdesc = Terminal utility that reads words from stdin or a file and creates an interactive selection window at the cursor location without clearing the screen
+ pkgver = 0.9.16
pkgrel = 1
url = https://github.com/p-gen/smenu
arch = x86_64
license = GPL
depends = ncurses
- source = smenu.tar.gz::https://github.com/p-gen/smenu/archive/v0.9.11.tar.gz
- sha256sums = ac6b8b94aa5382a0227753bd2c580fd727c7ce19adf72592993dd982b0af478f
+ source = smenu-0.9.16.tar.gz::https://github.com/p-gen/smenu/archive/v0.9.16.tar.gz
+ sha256sums = 8db8026a8d95f01b9a4b775834432b15cfd248868ef2a2ec1232bd534d26dc09
pkgname = smenu
diff --git a/PKGBUILD b/PKGBUILD
index f094d2957b5d..df30ebdd5e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-# Maintainer: Morten Linderud <foxboron@archlinux.org>
+# Maintainer: Filipe Nascimento <flipee at tuta dot io>
+# Contributor: Morten Linderud <foxboron@archlinux.org>
pkgname=smenu
-pkgver=0.9.11
+pkgver=0.9.16
pkgrel=1
-pkgdesc="Terminal utility that allows you to use words coming from the standard input to create a nice selection window just
-below the cursor. Once done, your selection will be sent to standard output."
+pkgdesc="Terminal utility that reads words from stdin or a file and creates an interactive
+selection window at the cursor location without clearing the screen"
arch=('x86_64')
url="https://github.com/p-gen/smenu"
license=('GPL')
depends=('ncurses')
-source=("${pkgname}.tar.gz::https://github.com/p-gen/smenu/archive/v${pkgver}.tar.gz")
-sha256sums=('ac6b8b94aa5382a0227753bd2c580fd727c7ce19adf72592993dd982b0af478f')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/p-gen/smenu/archive/v${pkgver}.tar.gz")
+sha256sums=('8db8026a8d95f01b9a4b775834432b15cfd248868ef2a2ec1232bd534d26dc09')
build() {
- cd "${pkgname}-${pkgver}"
- ./autogen.sh
- ./configure --prefix="/usr"
- make
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
}