summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Pierre Cimalando2020-07-04 08:13:00 +0200
committerJean Pierre Cimalando2020-07-04 08:13:06 +0200
commit048e3690ffbedc3da415fc5c1a84318f30a322c9 (patch)
tree57937b6fe3c60aa192f3cacdd586d0fcfb62a00c
downloadaur-048e3690ffbedc3da415fc5c1a84318f30a322c9.tar.gz
Initial
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD67
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..123aecba848a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = smf-dsp-git
+ pkgdesc = Advanced MIDI file player, including various chip music synths
+ pkgver = 0.0.0.r201.ge28e01e
+ pkgrel = 1
+ url = https://github.com/jpcima/smf-dsp
+ arch = x86_64
+ license = Boost
+ makedepends = git
+ makedepends = cmake
+ depends = sdl2
+ depends = sdl2_image
+ depends = jack
+ depends = alsa-lib
+ depends = libuv
+ depends = icu
+ depends = xdg-utils
+ source = git+https://github.com/jpcima/smf-dsp.git
+ source = git+https://github.com/Wohlstand/libADLMIDI.git
+ source = git+https://github.com/Wohlstand/libOPNMIDI.git
+ source = git+https://github.com/jpcima/scc.git
+ source = git+https://github.com/munt/munt.git
+ source = git+https://github.com/divideconcept/FluidLite.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = smf-dsp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6db5f2a04c04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Jean Pierre Cimalando <jp-dev@inbox.ru>
+pkgname=smf-dsp-git
+_pkgname=smf-dsp
+pkgver=0.0.0.r201.ge28e01e
+pkgrel=1
+epoch=
+pkgdesc="Advanced MIDI file player, including various chip music synths"
+arch=('x86_64')
+url="https://github.com/jpcima/smf-dsp"
+license=('Boost')
+groups=()
+depends=('sdl2' 'sdl2_image' 'jack' 'alsa-lib' 'libuv' 'icu' 'xdg-utils')
+makedepends=('git' 'cmake')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/jpcima/smf-dsp.git"
+ "git+https://github.com/Wohlstand/libADLMIDI.git"
+ "git+https://github.com/Wohlstand/libOPNMIDI.git"
+ "git+https://github.com/jpcima/scc.git"
+ "git+https://github.com/munt/munt.git"
+ "git+https://github.com/divideconcept/FluidLite.git")
+noextract=()
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ git config submodule.thirdparty/libADLMIDI.url "$srcdir"/libADLMIDI
+ git config submodule.thirdparty/libOPNMIDI.url "$srcdir"/libOPNMIDI
+ git config submodule.thirdparty/scc.url "$srcdir"/scc
+ git config submodule.thirdparty/munt.url "$srcdir"/munt
+ git config submodule.thirdparty/FluidLite.url "$srcdir"/FluidLite
+ git submodule update
+}
+
+build() {
+ cd "$_pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
+ cd ..
+ make -C build
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" -C build install
+ install -D -m644 LICENSE.md "$pkgdir"/usr/share/licenses/"$_pkgname"/LICENSE.md
+}