summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrakod2024-03-28 22:18:19 +0530
committerfrakod2024-03-28 22:18:19 +0530
commite1de7625dde9ffe7260b388cd0b99b1627b870c5 (patch)
tree2bf59b677525c7ea2efd8d0cdfb070cf2ca90a74
downloadaur-e1de7625dde9ffe7260b388cd0b99b1627b870c5.tar.gz
initial
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e812c327216c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = smol_img
+ pkgdesc = Quick Image Editor with automatic resizing to reach target JPG/PNG size.
+ pkgver = v1.3
+ pkgrel = 1
+ url = https://github.com/frak0d/smol_img
+ arch = pentium4
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL-3.0-only
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ source = git+https://github.com/frak0d/smol_img
+ md5sums = SKIP
+
+pkgname = smol_img
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3a057da0610
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: frakod <frakod@pm.me>
+
+pkgname='smol_img'
+pkgver='v1.3'
+pkgrel=1
+
+pkgdesc='Quick Image Editor with automatic resizing to reach target JPG/PNG size.'
+arch=(pentium4 i686 x86_64 armv7h aarch64)
+url='https://github.com/frak0d/smol_img'
+license=('GPL-3.0-only')
+
+depends=(qt5-base)
+makedepends=(git cmake)
+source=("git+$url")
+md5sums=('SKIP')
+
+prepare()
+{
+ cd $pkgname
+git git checkout $pkgver
+}
+
+build()
+{
+ cd $pkgname
+ cmake -S source -B build
+ cmake --build build --config Release
+}
+
+package()
+{
+ cmake --install $pkgname/build --prefix $pkgdir/usr
+}