summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Bruckner2017-03-24 01:07:20 +0100
committerMax Bruckner2017-03-24 02:51:52 +0100
commit58644a80be67942fbbc6b51fb5773da844e953f3 (patch)
tree82240bf9c1158ac993a4864a824da69f394a451c
downloadaur-58644a80be67942fbbc6b51fb5773da844e953f3.tar.gz
smooth-0.8.73.0_pre2
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD28
-rw-r--r--glib2-include.patch13
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..153802bd4ed1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Mar 24 01:43:04 UTC 2017
+pkgbase = smooth
+ pkgdesc = An object oriented C++ class library for Windows, OS X, Linux and most Unix-like operating systems
+ pkgver = 0.8.73.0_pre2
+ pkgrel = 1
+ url = http://www.smooth-project.org/
+ arch = i686
+ arch = x86_64
+ license = Artistic2.0
+ depends = fribidi
+ depends = gtk3
+ depends = libjpeg-turbo
+ depends = libxmu
+ depends = curl
+ source = https://downloads.sourceforge.net/project/smooth/smooth/0.8.73.0-pre2/smooth-0.8.73.0-pre2.tar.gz
+ source = glib2-include.patch
+ sha512sums = 1d64be4775c6bc12bc7a4f4bda0b84b695512d5344ee1c0e859ba8b417d2532df73a6bb9b7c5b43a713832ac5bf7ed0460ac4b377b759469ed674976c83b9ce0
+ sha512sums = cd2a48192fb6a1564088fc3179c953f0ed4112308dfa7347a3e536d4df561a8312f0ce1e607e9b4c865c5cec67612bf91e91f25e5d96c72d7b8829d834179028
+
+pkgname = smooth
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7208f839bc8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95bbf63f7648
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Max Bruckner <max at maxbruckner dot de>
+pkgname=smooth
+pkgver=0.8.73.0_pre2
+pkgrel=1
+pkgdesc="An object oriented C++ class library for Windows, OS X, Linux and most Unix-like operating systems"
+arch=('i686' 'x86_64')
+url="http://www.smooth-project.org/"
+license=('Artistic2.0')
+depends=('fribidi' 'gtk3' 'libjpeg-turbo' 'libxmu' 'curl')
+source=("https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver/_/-}/${pkgname}-${pkgver/_/-}.tar.gz" "glib2-include.patch")
+sha512sums=('1d64be4775c6bc12bc7a4f4bda0b84b695512d5344ee1c0e859ba8b417d2532df73a6bb9b7c5b43a713832ac5bf7ed0460ac4b377b759469ed674976c83b9ce0'
+ 'cd2a48192fb6a1564088fc3179c953f0ed4112308dfa7347a3e536d4df561a8312f0ce1e607e9b4c865c5cec67612bf91e91f25e5d96c72d7b8829d834179028')
+
+prepare() {
+ cd "$pkgname-${pkgver/_/-}" || exit 1
+ patch -p1 -i "$srcdir/glib2-include.patch"
+ find . -type f -exec sed -i 's!/usr/local!/usr!g' {} \;
+}
+
+build() {
+ cd "$pkgname-${pkgver/_/-}" || exit 1
+ make
+}
+
+package() {
+ cd "$pkgname-${pkgver/_/-}" || exit 1
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/glib2-include.patch b/glib2-include.patch
new file mode 100644
index 000000000000..6fd75ea63c43
--- /dev/null
+++ b/glib2-include.patch
@@ -0,0 +1,13 @@
+diff --git a/classes/gui/widgets/special/Makefile b/classes/gui/widgets/special/Makefile
+index 8229c17..5349e0c 100644
+--- a/classes/gui/widgets/special/Makefile
++++ b/classes/gui/widgets/special/Makefile
+@@ -8,6 +8,8 @@ include $(dir $(firstword $(MAKEFILE_LIST)))/$(SMOOTH_PATH)/Makefile-options
+ # Change these variables to fit your project:
+ ifeq ($(USE_BUNDLED_LIBFRIBIDI),True)
+ MYCCOPTS += -I$(SRCDIR)/$(SMOOTH_PATH)/include/support
++else
++ MYCCOPTS += -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
+ endif
+
+ # Enter object files here: