summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorN. Izumi2015-06-11 14:23:16 +0800
committerN. Izumi2015-06-11 14:23:16 +0800
commit52bff46073f931b05643255eb7a95e7244c62805 (patch)
tree7fb696efc23f4ad7d547114f5381804501a6d9e6
downloadaur-52bff46073f931b05643255eb7a95e7244c62805.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22affbdbf90e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = smp_utils
+ pkgdesc = Utilities for the Serial Attached SCSI (SAS) Management Protocol (SMP)
+ pkgver = 0.98
+ pkgrel = 1
+ url = http://sg.danny.cz/sg/smp_utils.html
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ source = http://sg.danny.cz/sg/p/smp_utils-0.98.tar.xz
+ sha1sums = 2c8296b0dc1f131a59729f4a8e46306a2938ad77
+ sha256sums = e1e470d0b851bd1b1a1dae8d831d4c1f1a9a62bad9eb1966b870a20100b886cc
+
+pkgname = smp_utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9718e51c724e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Dmitry Nosachev - quartz64 at gmail dot com
+# Maintainer: N.Izumi - izmntuk
+pkgname=smp_utils
+pkgver=0.98
+pkgrel=1
+pkgdesc="Utilities for the Serial Attached SCSI (SAS) Management Protocol (SMP)"
+arch=('i686' 'x86_64')
+url="http://sg.danny.cz/sg/smp_utils.html"
+license=('BSD')
+depends=('glibc')
+#options=('!libtool')
+source=("http://sg.danny.cz/sg/p/${pkgname}-${pkgver}.tar.xz")
+sha1sums=('2c8296b0dc1f131a59729f4a8e46306a2938ad77')
+sha256sums=('e1e470d0b851bd1b1a1dae8d831d4c1f1a9a62bad9eb1966b870a20100b886cc')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -dm755 "${pkgdir}"/usr/share/{licenses,doc}/"${pkgname}"
+ install -pm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -pm644 AUTHORS ChangeLog COVERAGE CREDITS NEWS README "${pkgdir}/usr/share/doc/${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}