summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormipimipi2018-12-17 20:47:36 +0100
committermipimipi2018-12-17 20:47:36 +0100
commitcd7f6bb534202f74cd7edf9c379b3fee3a270851 (patch)
tree5736f61ddee6d038c48393dc8894f0b45822c5be
parent9a7e6ef9950a2ee89f6b3f652c4497e571132698 (diff)
downloadaur-cd7f6bb534202f74cd7edf9c379b3fee3a270851.tar.gz
$1
-rwxr-xr-x.SRCINFO11
-rwxr-xr-xPKGBUILD30
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b40d62279578..fbd833441399 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = smsync-git
- pkgdesc = smsync (Smart Music Sync) keeps huge music collections in sync and is taking care of conversions between different file formats. It's an easy-to-use command line application for Linux.
- pkgver = 2.0.2
+ pkgdesc = smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application
+ pkgver = 3.0.2.r3.g3f7ed92
pkgrel = 1
- url = http://github.com/mipimipi/smsync/
+ url = https://github.com/mipimipi/smsync/
arch = x86_64
arch = i686
license = GPL3
- makedepends = go
- makedepends = git
- makedepends = sudo
+ makedepends = go-pie
+ makedepends = dep
depends = ffmpeg
source = git://github.com/mipimipi/smsync.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index af75c3c2fa9c..6f2aa0bd9a9a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Michael Picht <michael dot picht at ussenterprise dot de>
+pkgorg=github.com/mipimipi
pkgname=smsync-git
_pkgname=smsync
-pkgver=2.0.2
+pkgver=3.0.2.r3.g3f7ed92
pkgrel=1
-pkgdesc="smsync (Smart Music Sync) keeps huge music collections in sync and is taking care of conversions between different file formats. It's an easy-to-use command line application for Linux."
+pkgdesc="smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application"
arch=('x86_64' 'i686')
-url="http://github.com/mipimipi/$_pkgname/"
+url="https://$pkgorg/$_pkgname/"
license=('GPL3')
depends=('ffmpeg')
-makedepends=('go' 'git' 'sudo')
-source=("git://github.com/mipimipi/$_pkgname.git")
+makedepends=('go-pie' 'dep')
+source=("git://$pkgorg/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
@@ -19,20 +20,21 @@ pkgver() {
}
prepare() {
- cd "$_pkgname"
- export GOPATH=$(pwd)
- mkdir src
- ln -s -r vendor/github.com src/github.com
- ln -s -r vendor/golang.org src/golang.org
+ mkdir -p gopath/src/$pkgorg
+ ln -rTsf $_pkgname gopath/src/$pkgorg/$_pkgname
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$pkgorg/$_pkgname
+ dep ensure
}
build() {
- cd "$_pkgname"
- export GOPATH=$(pwd)
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$pkgorg/$_pkgname
make VERSION=$pkgver
}
package() {
- cd "$_pkgname"
- make DESTDIR=$pkgdir install
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$pkgorg/$_pkgname
+ make DESTDIR="$pkgdir" install
}