summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2015-06-15 13:11:41 -0500
committerGötz Christ2015-06-15 13:11:41 -0500
commit7fba54c731324c0cd6cb4da32000b279b2de0acd (patch)
treede252d86d3c41ca2a8692425c41bdde78c21b26b
downloadaur-7fba54c731324c0cd6cb4da32000b279b2de0acd.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
-rw-r--r--smtube.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5994367b8d2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = smtube-qt4
+ pkgdesc = Search, download and play videos from YouTube.
+ pkgver = 15.5.17
+ pkgrel = 1
+ url = http://smtube.sourceforge.net
+ install = smtube.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qtwebkit
+ optdepends = mplayer: play media with MPlayer
+ optdepends = smplayer: play media with SMPlayer
+ optdepends = gnome-mplayer: play media with GNOME MPlayer
+ optdepends = kdemultimedia-dragonplayer: play media with Dragon Player
+ optdepends = totem: play media with Totem
+ optdepends = vlc: play media with VLC
+ optdepends = mpv: play media with mpv
+ provides = smtube
+ conflicts = smtube
+ source = http://downloads.sourceforge.net/smtube/smtube-15.5.17.tar.bz2
+ md5sums = 577ebdf5fbcd3d17959294e688c124b4
+
+pkgname = smtube-qt4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7315d53ed3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=smtube-qt4
+pkgver=15.5.17
+pkgrel=1
+pkgdesc="Search, download and play videos from YouTube."
+arch=('i686' 'x86_64')
+url="http://smtube.sourceforge.net"
+license=('GPL')
+depends=('qtwebkit')
+optdepends=('mplayer: play media with MPlayer'
+ 'smplayer: play media with SMPlayer'
+ 'gnome-mplayer: play media with GNOME MPlayer'
+ 'kdemultimedia-dragonplayer: play media with Dragon Player'
+ 'totem: play media with Totem'
+ 'vlc: play media with VLC'
+ 'mpv: play media with mpv')
+provides=('smtube')
+conflicts=('smtube')
+install="smtube.install"
+source=("http://downloads.sourceforge.net/smtube/smtube-$pkgver.tar.bz2")
+md5sums=('577ebdf5fbcd3d17959294e688c124b4')
+
+build() {
+ cd smtube-$pkgver
+ make PREFIX=/usr QMAKE=qmake-qt4 LRELEASE=lrelease-qt4
+}
+
+package() {
+ cd smtube-$pkgver
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}
diff --git a/smtube.install b/smtube.install
new file mode 100644
index 000000000000..029294d67005
--- /dev/null
+++ b/smtube.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}