summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Li2018-01-11 10:54:08 -0500
committerJoshua Li2018-01-11 10:54:08 -0500
commitc6638aa1366df5f1ba6f8dcfc55113d2ee678ce8 (patch)
treead2601a00eb52bbd301b786e791efd9e0a868098
downloadaur-c6638aa1366df5f1ba6f8dcfc55113d2ee678ce8.tar.gz
2.0.42 release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a64a0c5da76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sn-bin
+ pkgdesc = A simple and private notes app.
+ pkgver = 2.0.42
+ pkgrel = 1
+ url = https://github.com/standardnotes/desktop
+ arch = x86_64
+ license = GPL3
+ provides = sn
+ noextract = standard-notes-2.0.42-x86_64.AppImage
+ options = !strip
+ source_x86_64 = https://github.com/standardnotes/desktop/releases/download/v2.0.42/standard-notes-2.0.42-x86_64.AppImage
+ sha256sums_x86_64 = 55aa58ebd78a4186d190895042009047c6b346626df185ddb478b54a2098f318
+
+pkgname = sn-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f4851fd6b5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: JoshuaRLi <joshua.r.li.98 at gmail com>
+pkgname=sn-bin
+pkgver=2.0.42
+pkgrel=1
+pkgdesc="A simple and private notes app."
+arch=('x86_64')
+url="https://github.com/standardnotes/desktop"
+license=('GPL3')
+provides=('sn')
+
+source_x86_64=("https://github.com/standardnotes/desktop/releases/download/v${pkgver}/standard-notes-${pkgver}-x86_64.AppImage")
+noextract=("standard-notes-${pkgver}-x86_64.AppImage")
+# stripping an AppImage binary will pretty much destroy it, so tell makepkg not to do so
+options=(!strip)
+sha256sums_x86_64=('55aa58ebd78a4186d190895042009047c6b346626df185ddb478b54a2098f318')
+
+package () {
+ install -Dm 775 "standard-notes-${pkgver}-x86_64.AppImage" "${pkgdir}/usr/bin/sn"
+}