summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2016-11-19 13:18:07 +0100
committerValHue2016-11-19 13:18:07 +0100
commita97d386fd02c8bdf1941e24e4289c13f044cde18 (patch)
tree4a052a77b765cc9f7cd40ccf0283b25faa05888e
downloadaur-a97d386fd02c8bdf1941e24e4289c13f044cde18.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD60
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..746f0c5a8380
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = snap4arduino
+ pkgdesc = A modification of the Snap! visual programming language that lets you seamlessly interact with almost all versions of the Arduino board.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://snap4arduino.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = nss
+ depends = libxtst
+ depends = alsa-lib
+ depends = libxss
+ depends = gtk2
+ depends = gconf
+ depends = freetype2-ubuntu
+ provides = snap4arduino
+ source_i686 = http://snap4arduino.org/downloads/1.2.1/Snap4Arduino_desktop-gnu-32_1.2.1.tar.gz
+ sha256sums_i686 = ece65ce5b901b29d70e54494f757aa46e439911a7192f3c861b36a8cb9f9f580
+ source_x86_64 = http://snap4arduino.org/downloads/1.2.1/Snap4Arduino_desktop-gnu-64_1.2.1.tar.gz
+ sha256sums_x86_64 = 3192a572384e28d49c6549fd038d5e47e9739c0a6e4b2b4e1b853c72630413bd
+
+pkgname = snap4arduino
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b07d597cfc2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+_pkgname="Snap4Arduino_desktop-gnu"
+pkgname="snap4arduino"
+pkgver="1.2.1"
+pkgrel="1"
+pkgdesc="A modification of the Snap! visual programming language that lets you seamlessly interact with almost all versions of the Arduino board."
+arch=('i686' 'x86_64')
+url="http://snap4arduino.org/"
+license=('GPL3')
+depends=('nss' 'libxtst' 'alsa-lib' 'libxss' 'gtk2' 'gconf' 'freetype2-ubuntu')
+provides=("${pkgname}")
+
+source_i686=("http://${pkgname}.org/downloads/${pkgver}/Snap4Arduino_desktop-gnu-32_${pkgver}.tar.gz")
+source_x86_64=("http://${pkgname}.org/downloads/${pkgver}/Snap4Arduino_desktop-gnu-64_${pkgver}.tar.gz")
+
+sha256sums_i686=('ece65ce5b901b29d70e54494f757aa46e439911a7192f3c861b36a8cb9f9f580')
+sha256sums_x86_64=('3192a572384e28d49c6549fd038d5e47e9739c0a6e4b2b4e1b853c72630413bd')
+
+if [[ $CARCH == i686 ]]; then
+ _dir="32";
+else
+ _dir="64";
+fi
+
+build() {
+ cd "${_pkgname}-${_dir}_${pkgver}"
+ sed -i "s|Icon=|Icon=/opt/Snap4Arduino/icons/128x128x32.png|g" Snap4Arduino.desktop
+ sed -i "s|cd \$(dirname %k)|cd /opt/Snap4Arduino/|g" Snap4Arduino.desktop
+}
+
+package() {
+ cd "${_pkgname}-${_dir}_${pkgver}"
+
+ # Data
+ install -d ${pkgdir}/opt/${pkgname}/{icons,lib,locales,pnacl}
+ install -m 644 icons/* "${pkgdir}/opt/${pkgname}/icons/"
+ install -m 755 lib/* "${pkgdir}/opt/${pkgname}/lib/"
+ install -m 644 locales/* "${pkgdir}/opt/${pkgname}/locales/"
+ install -m 644 pnacl/* "${pkgdir}/opt/${pkgname}/pnacl/"
+ rm -rf ./{icons,lib,locales,pnacl}
+ chmod +x ${pkgdir}/opt/${pkgname}/pnacl/*_nexe
+
+ # Desktop file
+ install -Dm 644 Snap4Arduino.desktop "${pkgdir}/usr/share/applications/Snap4Arduino.desktop"
+ rm Snap4Arduino.desktop
+
+ # License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm LICENSE
+
+ # Rest of data
+ install -m 644 ./* "${pkgdir}/opt/${pkgname}/"
+
+ # Fix for permissions
+ chmod +x ${pkgdir}/opt/${pkgname}/{chromedriver,launcher*,minidump_stackwalk,nacl_*,nwjc,payload,run}
+}
+
+# vim:set ts=4 sw=2 ft=sh et: