summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2018-01-05 11:08:02 +0100
committerValHue2018-01-05 11:08:02 +0100
commitffe14083b95c893e058557be26abd6a01d1130e5 (patch)
treeed9ccf5e99916c743b0d2aa4c3e4449e800e2f93
parent62eadf7ad86ef40599ce28833cc5ed5d193029dd (diff)
downloadaur-ffe14083b95c893e058557be26abd6a01d1130e5.tar.gz
Update to 1.2.4-3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD39
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 098dc35c85ef..3831580f7ce8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snap4arduino
pkgdesc = A modification of the Snap! visual programming language that lets you seamlessly interact with almost all versions of the Arduino board.
pkgver = 1.2.4
- pkgrel = 2
+ pkgrel = 3
url = http://snap4arduino.rocks/
arch = i686
arch = x86_64
@@ -15,6 +15,7 @@ pkgbase = snap4arduino
depends = gconf
depends = freetype2
provides = snap4arduino
+ options = !strip
source_i686 = https://github.com/bromagosa/snap4arduino/releases/download/1.2.4/Snap4Arduino_desktop-gnu-32_1.2.4.tar.gz
sha256sums_i686 = e25d5c06be8fec042d5853e73386738bfb39e6ab772cf4b95c86122468dca6ad
source_x86_64 = https://github.com/bromagosa/snap4arduino/releases/download/1.2.4/Snap4Arduino_desktop-gnu-64_1.2.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 84d734fb8275..3023ebd609de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: ValHue <vhuelamo at gmail dot com>
-# https://github.com/ValHue/AUR-PKGBUILDs
#
# Contributor: ValHue <vhuelamo at gmail dot com>
#
_pkgname="Snap4Arduino_desktop-gnu"
+_tname="Snap4Arduino"
pkgname="snap4arduino"
pkgver="1.2.4"
-pkgrel="2"
+pkgrel="3"
pkgdesc="A modification of the Snap! visual programming language that lets you seamlessly interact with almost all versions of the Arduino board."
arch=('i686' 'x86_64')
url="http://snap4arduino.rocks/"
license=('AGPL3' 'MIT')
depends=('nss' 'libxtst' 'alsa-lib' 'libxss' 'gtk3' 'gconf' 'freetype2')
provides=("${pkgname}")
+options=('!strip')
source_i686=("https://github.com/bromagosa/${pkgname}/releases/download/${pkgver}/${_pkgname}-32_${pkgver}.tar.gz")
source_x86_64=("https://github.com/bromagosa/${pkgname}/releases/download/${pkgver}/${_pkgname}-64_${pkgver}.tar.gz")
@@ -28,36 +29,38 @@ fi
build() {
cd "${_pkgname}-${_dir}_${pkgver}"
- sed -i "s|Icon=|Icon=/opt/snap4arduino/icons/128x128x32.png|g" Snap4Arduino.desktop
- sed -i "s|cd \$(dirname %k)|cd /opt/snap4arduino/|g" Snap4Arduino.desktop
+ sed -i "s|Icon=|Icon=/opt/${_tname}/icons/128x128x32.png|g" ${_tname}.desktop
+ sed -i "s|cd \$(dirname %k)|cd /opt/${_tname}/|g" ${_tname}.desktop
+ sed -i "s|launcher.sh|run|g" ${_tname}.desktop
}
package() {
cd "${_pkgname}-${_dir}_${pkgver}"
# Data
- install -d ${pkgdir}/opt/${pkgname}/{icons,lib,locales,pnacl,swiftshader}
- install -m 644 icons/* "${pkgdir}/opt/${pkgname}/icons/"
- install -m 755 lib/* "${pkgdir}/opt/${pkgname}/lib/"
- install -m 644 locales/* "${pkgdir}/opt/${pkgname}/locales/"
- install -m 644 pnacl/* "${pkgdir}/opt/${pkgname}/pnacl/"
- install -m 644 swiftshader/* "${pkgdir}/opt/${pkgname}/swiftshader/"
+ install -d ${pkgdir}/opt/${_tname}/{icons,lib,locales,pnacl,swiftshader}
+ install -d ${pkgdir}/usr/share/{applications,licenses}
+ install -m 644 icons/* "${pkgdir}/opt/${_tname}/icons/"
+ install -m 755 lib/* "${pkgdir}/opt/${_tname}/lib/"
+ install -m 644 locales/* "${pkgdir}/opt/${_tname}/locales/"
+ install -m 644 pnacl/* "${pkgdir}/opt/${_tname}/pnacl/"
+ install -m 644 swiftshader/* "${pkgdir}/opt/${_tname}/swiftshader/"
rm -rf ./{icons,lib,locales,pnacl,swiftshader}
- chmod +x ${pkgdir}/opt/${pkgname}/pnacl/*_nexe
-
- # Desktop file
- install -Dm 644 Snap4Arduino.desktop "${pkgdir}/usr/share/applications/Snap4Arduino.desktop"
- rm Snap4Arduino.desktop
+ chmod +x ${pkgdir}/opt/${_tname}/pnacl/*_nexe
+ # Desktop file
+ install -Dm 644 ${_tname}.desktop "${pkgdir}/usr/share/applications/${_tname}.desktop"
+ rm ${_tname}.desktop
+
# License
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm LICENSE
# Rest of data
- install -m 644 ./* "${pkgdir}/opt/${pkgname}/"
+ install -m 644 ./* "${pkgdir}/opt/${_tname}/"
# Fix for permissions
- chmod +x ${pkgdir}/opt/${pkgname}/{chromedriver,launcher*,minidump_stackwalk,nacl_*,nwjc,payload,run}
+ chmod +x ${pkgdir}/opt/${_tname}/{chromedriver,launcher*,minidump_stackwalk,nacl_*,nwjc,payload,run}
}
-# vim:set ts=4 sw=2 ft=sh et:
+# vim:set ts=4 sw=2 ft=sh et syn=sh ft=sh: