summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart De Vries2016-01-01 22:24:00 +0100
committerBart De Vries2016-01-01 22:24:00 +0100
commit40d964b9c15f9cbc67a522af2c795bbab933e2d9 (patch)
tree3bc8c0ed6a41eef6f6ad55974f90a2f0a7425062
downloadaur-40d964b9c15f9cbc67a522af2c795bbab933e2d9.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
-rw-r--r--snapcast-systemd.patch22
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe9e30708dcd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Fri Jan 1 21:23:07 UTC 2016
+pkgbase = snapcast
+ pkgdesc = Synchronous multi-room audio player
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/badaix/snapcast
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ makedepends = git
+ makedepends = boost
+ makedepends = alsa-utils
+ depends = boost-libs
+ depends = alsa-lib
+ depends = avahi
+ depends = libvorbis
+ depends = flac
+ source = https://github.com/badaix/snapcast/archive/v0.4.0.tar.gz
+ source = snapcast-systemd.patch
+ md5sums = ee13041c5e8a9b84fc00b03ba4d713cf
+ md5sums = 156ea081ab151786ca8e508636f07f45
+
+pkgname = snapcast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec336936a0f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Bart De Vries <devriesb@gmail.com>
+
+pkgname=snapcast
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Synchronous multi-room audio player"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/badaix/snapcast"
+license=('GPL')
+groups=()
+depends=(boost-libs alsa-lib avahi libvorbis flac)
+makedepends=(git boost alsa-utils)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/badaix/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}-systemd.patch")
+noextract=()
+md5sums=('ee13041c5e8a9b84fc00b03ba4d713cf'
+ '156ea081ab151786ca8e508636f07f45')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/$pkgname-systemd.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 -g root -o root server/snapserver ${pkgdir}/usr/bin/snapserver
+ install -Dm644 -g root -o root server/snapserver.1 ${pkgdir}/usr/share/man/man1/snapserver.1
+
+ install -Dm755 -g root -o root client/snapclient ${pkgdir}/usr/bin/snapclient
+ install -Dm644 -g root -o root client/snapclient.1 ${pkgdir}/usr/share/man/man1/snapclient.1
+
+ install -Dm644 -g root -o root init.scripts/systemd/snapserver.service ${pkgdir}/usr/lib/systemd/system/snapserver.service
+ install -Dm644 -g root -o root init.scripts/systemd/snapclient.service ${pkgdir}/usr/lib/systemd/system/snapclient.service
+}
+
diff --git a/snapcast-systemd.patch b/snapcast-systemd.patch
new file mode 100644
index 000000000000..558ca2b46a95
--- /dev/null
+++ b/snapcast-systemd.patch
@@ -0,0 +1,22 @@
+diff -aur snapcast-0.4.0/init.scripts/systemd/snapclient.service snapcast-0.4.0.new/init.scripts/systemd/snapclient.service
+--- snapcast-0.4.0/init.scripts/systemd/snapclient.service 2015-12-28 13:58:35.000000000 +0100
++++ snapcast-0.4.0.new/init.scripts/systemd/snapclient.service 2016-01-01 21:42:38.169018147 +0100
+@@ -1,6 +1,7 @@
+ [Unit]
+ Description=Snapcast client
+ After=network.target
++Requires=avahi-daemon.service
+
+ [Service]
+ Type=forking
+diff -aur snapcast-0.4.0/init.scripts/systemd/snapserver.service snapcast-0.4.0.new/init.scripts/systemd/snapserver.service
+--- snapcast-0.4.0/init.scripts/systemd/snapserver.service 2015-12-28 13:58:35.000000000 +0100
++++ snapcast-0.4.0.new/init.scripts/systemd/snapserver.service 2016-01-01 21:42:48.855684354 +0100
+@@ -1,6 +1,7 @@
+ [Unit]
+ Description=Snapcast server
+ After=network.target
++Requires=avahi-daemon.service
+
+ [Service]
+ Type=forking